Configure SNMP on Cisco 2960 Switches

I have high T-1 utilization, causing packet loss. I want to track down what device(s) are responsible. I have Cisco WS-C2960G-48TC-L and WS-C2960-24TT-L switches. I am running a trial of OpManager. I need to configure SNMP traps on the switches so OpManager's Switch Port Mapper will tell me what ports are handling the most bandwidth. Then I can go to the switch and check what device(s) is on that port(s). The IOS on the 48s is C2960-LANBASEK9-M, version 12.2(44)SE6. The IOS on the 24s is C2960-LANBASE-M, version 12.2(35)SE5

If someone could tell me the simplest way to configure SNMP on these switches for this purpose, or knows a better way to track down the bandwidth hogs, I would appreciate it!
disciple_of_chim-chimAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
SteveConnect With a Mentor Network ManagerCommented:

snmp-server community <readonly password> RO
snmp-server community <readwrite password> RW

then you can use MRTG or other SNMP monitoring software to graph all the ports on the switches..





0
 
pgolding00Commented:
it might be quicker to configure ip accounting, assuming the code you have supports it, then see what ip addresses are doing the most damage. depending on the config you have, add the command "ip accounting" under an interface where you have an ip address configured, either the physical ports or vlan interface.
0
 
kenbitCommented:
Hi,

Answer to your query -
1. Configure snmp passwordl as below on your 2960 switch
snmp-server community <PasswordHere> RO
2. In OpManager provide snmp password for the switch along with MIB OID for the switch
3. That's it, you can start analysing the traffic on your opmanager nms

Additionally
If you want quick way to track the high BW utilizing port
Just console/telnet your switch and in privilege mode type (tell me, if you want easy steps to console/telnet)
#show interfaces counters -  to view instant results.

Example below:
Switch2960#show interfaces counters

Port            InOctets   InUcastPkts   InMcastPkts   InBcastPkts
Fa0/1          305003731       1501680             9         14668
Fa0/2          261523502       1321248             0          6493
Fa0/3         3621151603       3622220             0          9463

Let me know if this answers your query and solve your issue
0
 
disciple_of_chim-chimAuthor Commented:
Small detail, but without it the solution is unusable. To enable SNMP, you must be at the "Router(config)#" prompt. To get there, the
"Router#configure terminal" command is necessary.
Thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.