Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

A certification error when open MS Outlook

This is a newly-installed MS Exchange 2007 server, that was migrated from Exchange 2003. All Outlook also upgraded from 2003 to 2007. Whenever user open the MS Outlook, he/her will see a certificate error. Even if the user select to import the cert, same error will still prompt subsequently.
All the outlook are configured to use Exchange Cache mode in RPC. Any suggestion is welcome.
0
Balack
Asked:
Balack
5 Solutions
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Yes this is due to your virtual directories being different that the cert.    

EXCHANGESERVERNAME = Exchange 2007 Server name

exchange.ourcompany.com = whatever your cert is set for on OWA

The Cmdlet fix:

Set-ClientAccessServer -Identity EXCHANGESERVERNAME -AutoDiscoverServiceInternalUri https://exchange.ourcompany.com/Autodiscover/Autodiscover.xml

Set-WebServicesVirtualDirectory -Identity "EXCHANGESERVERNAME\EWS (Default Web Site)" -InternalURL https://exchange.ourcompany.com/EWS/Exchange.asmx -BasicAuthentication:$true

Set-OABVirtualDirectory -Identity "EXCHANGESERVERNAME\OAB (Default Web Site)" -InternalURL https://exchange.ourcompany.com/OAB

Set-ActiveSyncVirtualDirectory -Identity "EXCHANGESERVERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ExternalURL https://exchange.ourcompany.com/Microsoft-Server-Activesync 


0
 
lastlostlastCommented:
what is the certificate when you click on view certificate option in the certificate error?

By defauult for your internal clients to connect with Exchange Server, they will connect using the URL set in SCP. Default is https://FQDN/autodiscover/autodiscover.xml

If you are using a single name certificate in the IIS, then you will need to modify the SCP URL as mentioned above.

You can go through KB 940726 for more details.
0
 
MesthaCommented:
Ideally you need to change the self generated certificate that Exchange 2007 installs for a commercial SAN/UC certificate. That will allow you to use all of the Exchange 2007 features without certificate prompts.

I have outlined what needs to be done on my web site here:
http://blog.sembee.co.uk/archive/2008/05/30/78.aspx

Simon.
0
 
aslamsurveCommented:
Check the following......
Warning message when you start Outlook 2007 and then connect to a mailbox that is hosted on an Exchange 2007-based server: "The name of the security certificate is invalid or does not match the name of the site"
http://support.microsoft.com/kb/940726
0
 
canuc0Commented:
Exchange 2007 assigns a self-signed certificate which is valid for a year. As you haven't installed this a year ago, and have recently done a migration, it's most likely an issue with IIS running on the Exchange server.

You can also get some information about your Outlook connectivity by ctrl and right-clicking the Outlook icon in the system tray.

If you use external connectivity, such as OWA, go with Mestha's recommendation of a SAN certificate - it will save you a lot of heartache, both for internal and external issues with certs.
Hope this is helpful,
canuc0
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now