How do I get rid of "Cannot send session cache limiter - headers already sent "?

I'm using flash/xml site template from flashden. while the site is under construction I have added a login module using sessions so that only the guys who are working on the project can view the pages.
My problem is that after login, when my page is redirected to the home page, I get the warning as follows:
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent....
I have gone over the same problem posted on our Experts Exchange and tried some solutions offered in vain. The session_start() is on the first line after the <?php delimiter and ther is also no white space anywhere...
Can someone please help me to solve this issue? Thanks in advance.
<?php session_start(); 
 
if($_SESSION['admin'] && $_SESSION['admin'] != ""){
//do nothing
}else{
echo "<script language=\"JavaScript\">location.replace(\"index.html\"); </script>";
}
	
	?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
// Rest of the code

Open in new window

786aslamkhanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BrianMMCommented:
Might seem trivial but try it like this.
<?php
session_start();
...stuff

Open in new window

0
fluglashCommented:
post some code from the beginning of your index.html, please
0
BrianMMCommented:
failing that, it's a problem saving the file... most likley text encoding of whatever editor you are using.
0
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

jet-blackCommented:
If you are using UTF-8 encoding,
uncheck "Include Unicode Signature (BOM)".
before saving.
0
pmessanaCommented:
Much like Brian said but I would go a bit further to keep it clean and ensure that it is getting parsed correctly.
<?php
 
session_start(); 
 
if($_SESSION['admin'] && $_SESSION['admin'] != ""){
  //do nothing
}else{
  echo "<script language=\"JavaScript\">location.replace(\"index.html\"); </script>";
}
        
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
// Rest of the code

Open in new window

0
786aslamkhanAuthor Commented:
Thanks BrianMM for your response. I tried putting session_start() on the second line as suggested- does not work.

Thanks jet-black I tried saving the file by unchecking the "Include Unicode Signature (BOM)". Does not work.

Thanks pmessana for your suggestion.

Thanks fluglash!

I have attached the whole file, so you all can have a look.

Thanks again BrianMM, jet-black, pmessana and fluglash.


<?php session_start(); 
 
if($_SESSION['some_name'] && $_SESSION['some_name'] != ""){
//do nothing
}else{
echo "<script language=\"JavaScript\">location.replace(\"index.html\"); </script>";
}
	
	?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="Author" content="author">
<meta name="keywords" content="keywords" />
<meta name="description" content="desc" />
<title>Title</title>
 
<script type="text/javascript" src="swfobject.js"></script>
<script type="text/javascript" src="swfaddress.js"></script>
<script type="text/javascript" src="swffit.js"></script>
 
 
<style type="text/css">
	/* hide from ie on mac \*/
	html {
		height: 100%;
		overflow: hidden;
	}
	
	#flashcontent {
		height: 100%;
	}
	/* end hide */
 
	body {
		height: 100%;
		margin: 0;
		padding: 0;
		background-color: #0d0d0d;
	}
	p {
 
	font-size: 10px;
	font-family: Verdana;
	line-height:17px;
	color:#999999;
	
}
#apDiv1 {
	position:absolute;
	left:454px;
	top:58px;
	width:197px;
	height:37px;
	z-index:1;
}
#apDiv2 {
	position:absolute;
	left:442px;
	top:481px;
	width:261px;
	height:51px;
	z-index:2;
}
#apDiv3 {
	position:absolute;
	left:443px;
	top:114px;
	width:267px;
	height:53px;
	z-index:1;
}
#apDiv4 {
	position:absolute;
	left:500px;
	top:440px;
	width:262px;
	height:52px;
	z-index:1;
}
#Layer1 {
	position:absolute;
	left:447px;
	top:176px;
	width:53px;
	height:21px;
	z-index:1;
}
.style3 {
	color: #FFFFFF;
	font-family: Verdana, Arial, Helvetica, sans-serif;
}
#Layer2 {
	position:absolute;
	left:372px;
	top:68px;
	width:101px;
	height:22px;
	z-index:1;
}
</style>
<script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
<script type="text/javascript">
<!--
function MM_popupMsg(msg) { //v1.0
  alert(msg);
}
//-->
</script>
</head>
<body onload="MM_popupMsg('Right_Click Mouse  to select Full Screen option.\rIt\'s Recommended!')">
<div id="flashcontent"> 
 
  <p style="color:#999999">
    You need Adobe Flash Player 9.0.115 to visit this site.</p>
  <hr width="360" align="left"/>
 <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="" /></a></p>
</div>
    
 	 
	
<script type="text/javascript">
   	var flashvars = {};
	flashvars.url_config="xml/configuration_site.xml";
	flashvars.initServices=true;
	var params = { allowfullscreen:true,allowScriptAccess:"always" };
	var attributes = { id:'flashObject' }; // give an id to the flash object
	
	swfobject.embedSWF("index.swf", "flashcontent", "100%", "100%", "8", "expressInstall.swf", flashvars, params,attributes);
	//swffit.fit("flashObject",900,620);
</script>
	     
 
 
</body>
</html>

Open in new window

0
jet-blackCommented:
786aslamkhan,

There is no problem about your code.
The error you are facing is resulting because of there is hidden characters before <?php tag.

You can download
RapidPHP http://www.blumentals.net/rapidphp/
Then select Options->Show Hidden Characters

And remove the hidden characters then save the file.

Also,
you can attach the zip file and we remove the hidden characters.
0
jet-blackCommented:
or simply download
http://www.crimsoneditor.com/download/cedt370r.exe

open your file,
then choose Document->Encoding Type->UTF-8 Encoding(w/o BOM)

And save your file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
786aslamkhanAuthor Commented:
Thanks a ton jet-black! it worked! my problem solved. AND I HAVE LEARNED FROM YOU.
THANK YOU SO VERY MUCH!!!!!!!!!!!
0
jet-blackCommented:
Welcome :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.