Weird Problem with Exchange 2003 SP2 GAL

I have a very weird thing happening with Exchnage 2003 SP2 and AD. Recently some users are not showing in the GAL. Some of these users have been in AD for years. I notice that if I run ADSI edit and look at one of the users, the showinaddressbook attribute is not set and then when I look again seconds later it is set.
This replicates in the GAL with the user being there one second and gone the next. I can create new users that work OK.

Any ideas?
TButtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SubsunCommented:
Is there any applications/Script which makes use of GAL?
Are you using any software or script for GAL synchronization?

Turn on diagnostic logging for following and see if there any error.
MSExchangeAL \ LDAP Operations
MSExchangeAL \ Address List Synchronization
MSExchangeSA \ Proxy Generation

Also just remove the Automatically Update Email Addresses option from user email addresses tab and test it the issue persists or not.
0
TButtAuthor Commented:
I am not aware of any apps or scripts using the GAL, or any other software synchronisation.

We have turned those diagnostices on and have not yet seen any errors. I have manually updates the RUS and rebuilt the OAB and still no errors.

I have just turned off the check box as asked the users are stll appearing and disappearing from the GAL i can see this when using OWA and searching for them.
0
TButtAuthor Commented:
It looks as if a restart of the DC may have resolved this. I will monitor over the next few days and report back.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

SubsunCommented:
Run dcdiag and netdiag and see if any errors are there..
0
TButtAuthor Commented:
I believe that we have fixed this by rebuilding the RUS yesterday. The GAL n apears to be working as normal
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.