Solved

Weird Problem with Exchange 2003 SP2 GAL

Posted on 2009-07-10
6
202 Views
Last Modified: 2012-05-07
I have a very weird thing happening with Exchnage 2003 SP2 and AD. Recently some users are not showing in the GAL. Some of these users have been in AD for years. I notice that if I run ADSI edit and look at one of the users, the showinaddressbook attribute is not set and then when I look again seconds later it is set.
This replicates in the GAL with the user being there one second and gone the next. I can create new users that work OK.

Any ideas?
0
Comment
Question by:TButt
  • 3
  • 3
6 Comments
 
LVL 40

Expert Comment

by:Subsun
Comment Utility
Is there any applications/Script which makes use of GAL?
Are you using any software or script for GAL synchronization?

Turn on diagnostic logging for following and see if there any error.
MSExchangeAL \ LDAP Operations
MSExchangeAL \ Address List Synchronization
MSExchangeSA \ Proxy Generation

Also just remove the Automatically Update Email Addresses option from user email addresses tab and test it the issue persists or not.
0
 

Author Comment

by:TButt
Comment Utility
I am not aware of any apps or scripts using the GAL, or any other software synchronisation.

We have turned those diagnostices on and have not yet seen any errors. I have manually updates the RUS and rebuilt the OAB and still no errors.

I have just turned off the check box as asked the users are stll appearing and disappearing from the GAL i can see this when using OWA and searching for them.
0
 

Author Comment

by:TButt
Comment Utility
It looks as if a restart of the DC may have resolved this. I will monitor over the next few days and report back.
0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 40

Expert Comment

by:Subsun
Comment Utility
Run dcdiag and netdiag and see if any errors are there..
0
 
LVL 40

Expert Comment

by:Subsun
Comment Utility
0
 

Accepted Solution

by:
TButt earned 0 total points
Comment Utility
I believe that we have fixed this by rebuilding the RUS yesterday. The GAL n apears to be working as normal
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now