Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Free/Busy Information not available to Outlook 2007 users Exch2007 in coexistense with Exch2003

Posted on 2009-07-10
14
Medium Priority
?
1,303 Views
Last Modified: 2012-08-13
Hi,

I'm running Exchange 2007 SP1 in coexistence with Exchange 2003 & am in the process of migrating mailboxes. The majority of our users are on Outlook 2003 but some (including myself) are running Outlook 2007. Outlook 2007 users are unable to view free/busy information when scheduling appointments but Outlook 2003 users are. I f I try to view a colleagues free/busy information using Outlook 2007 I fail where if I use Outlook 2003 it works. My maiolbox is on Exchange 2007. I have replicated Public Folders from Exchange 2003 to 2007.

Does anyone have any ideas about how to fix this issue?

Thanks in advance!

Andrew
0
Comment
Question by:AndrewHuges
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +3
14 Comments
 
LVL 1

Expert Comment

by:fish64801
ID: 24824030
you didn't mention a time frame for free/busy schedule.  but it could be that the 2007 profiles have a different setting in calendar options for free busy time than the 2003 profiles
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24824044
So if you try to view the Free-busy of E2l7 user from Outlook 2007 you are unable to view.
try running this command Test-Outlookwebservices |fl see what you get.

Also check the test email aconfiguration in the outlook profile and check what are the URLS you are getting. See if your clients are conectig via SCP.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24824347
Outlook 2007 gets the free/busy information in a different way. It uses the availability service, which is part of the autodiscover system. Does autodiscover work correctly?

Simon.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 40

Expert Comment

by:Subsun
ID: 24824537
Test the availability using and see if its ok.
Test-OutlookWebServices -id:user@domain.com -TargetAddress: user1@domain.com
Ref :http://technet.microsoft.com/en-us/library/bb397225.aspx
0
 
LVL 4

Expert Comment

by:aletjolly
ID: 24836486
Kindly make sure Autodiscover is working perfectly as Free/busy in Exchange 2007 when using Outlook 2007 depends on Autodiscover to wor. Find below articles for same:
http://technet.microsoft.com/en-us/library/bb332063.aspx
http://technet.microsoft.com/en-us/library/bb397225.aspx
0
 

Accepted Solution

by:
AndrewHuges earned 0 total points
ID: 24838199
Hi Guys,

Thanks for the responses, much appreciated! I've managed to fix the issue by simply creating a DNS A record for the Autodiscover server on our domain, slightly embarrassing!
We know have the situation that Outlook 2007 clients whos mailbox is on Exchange 2007 cant see free/busy information for users who are using Outlook 2003 regardless of whether their mailbox is on Exchange 2003 or 2007! Any more ideas?

Thanks
Andrew
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24838318
Open Exchange 2003 ESM
Scroll to Administrative Groups > Folders
Right click Public Folders - View System Folders
Expand Schedule + Free Busy
Free Busy sub folders starting with EX: Right click each one properties, replication tab.
Check EX2k7 is available if not add your Ex2K7 server.
Force the replication..

Are they able to see the free/Busy in OWA?

Ask user to log on to mailbox using Outlook with switch /cleanfreebusy (in run type Outlook /cleanfreebusy and press enter)
http://support.microsoft.com/kb/945602/en-us 
0
 

Author Comment

by:AndrewHuges
ID: 24838809
Hi Subsun,

The E2K7 server is available in the replica settings for the E2K3 public folders.
E2K7 can't see the free/busy inormation usign OWA.
Will try the /cleanfreebusy control & get back to you.

Thanks
Andrew
0
 

Author Comment

by:AndrewHuges
ID: 24840171
Still no joy after the /cleanfreebusy.

Thanks
Andrew
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24840242
Make sure SSL is not enabled on the E2l3 Public virtual directory
0
 

Author Comment

by:AndrewHuges
ID: 24840308
SSL isn't configure on the E2K3 Public virtual directory in IIS6
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24840936
Can you paste the result of following command?
get-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse |fl
0
 

Author Comment

by:AndrewHuges
ID: 24842090
AgeLimit                       :
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A0300E6F089BB8455B943A254F8BE805D86EC0000000000040000
HasSubFolders                  : True
HiddenFromAddressListsEnabled  : False
LocalReplicaAgeLimit           :
MailEnabled                    : False
MaxItemSize                    :
Name                           : SCHEDULE+ FREE BUSY
ParentPath                     : \NON_IPM_SUBTREE
PerUserReadStateEnabled        : True
PostStorageQuota               :
Replicas                       : {}
ReplicationSchedule            : {}
RetainDeletedItemsFor          :
StorageQuota                   :
UseDatabaseAgeDefaults         : True
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : True
UseDatabaseRetentionDefaults   : True
Identity                       : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
IsValid                        : True
OriginatingServer              : Exchange 2007 Server

AgeLimit                       : 100.00:00:00
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A0300CC29DD60354E1C47BEF3955FC462F22F0000000000070000
HasSubFolders                  : False
HiddenFromAddressListsEnabled  : True
LocalReplicaAgeLimit           :
MailEnabled                    : False
MaxItemSize                    :
Name                           : EX:/o=Organisation /ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
ParentPath                     : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
PerUserReadStateEnabled        : True
PostStorageQuota               :
Replicas                       : {Public Folder Store (Exchange 2003 Server), Public Folder Database}
ReplicationSchedule            : {Sun.00:00-Sat.23:45, Sat.23:45-Sun.00:00}
RetainDeletedItemsFor          :
StorageQuota                   :
UseDatabaseAgeDefaults         : False
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : False
UseDatabaseRetentionDefaults   : True
Identity                       : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Organisation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
IsValid                        : True
OriginatingServer              : Exchange 2007 Server

AgeLimit                       : 100.00:00:00
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A03004C87C39A37B04340BE4BBC2224FF6E0D0000000000070000
HasSubFolders                  : False
HiddenFromAddressListsEnabled  : True
LocalReplicaAgeLimit           :
MailEnabled                    : True
MaxItemSize                    :
Name                           : EX:/o=Organisation/ou=First Administrative Group
ParentPath                     : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
PerUserReadStateEnabled        : True
PostStorageQuota               :
Replicas                       : {Public Folder Database}
ReplicationSchedule            : {}
RetainDeletedItemsFor          :
StorageQuota                   :
UseDatabaseAgeDefaults         : False
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : True
UseDatabaseRetentionDefaults   : True
Identity                       : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Organisation /ou=First Administrative Group
IsValid                        : True
OriginatingServer              : Exchange 2007 Server
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24843986
It seems 2007 free/busy doesn't have 2003 replica. Also check the replication schedule for both FB folders. Set it to always. If it doesn't resolve your issue then enable diagnostic logging and see if there any errors in replication.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question