We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Problem connecting Dreamweaver to MySql Database

Medium Priority
420 Views
Last Modified: 2013-12-13
Hi

 i have a static IP address they have been granted remote access giving me details shown below

We have now granted access to the "mysql1-remote.mylogin.ie" server from the 89.101.172.46 IP address as requested.  You should now be able to make remote connections over port 3306 using MySQL client software.

I am having problems with connecting to Mysql can anyone help

All the information i have entered is below.

 
Local Info

     Sitename                buildingbids

     Local root folder      C:\Documents and Settings\Main User\My Documents\WEB SITES\buildingbids\

     HTTP address          http://ftp1.reg365.net

 
Remote Info

     Access              FTP

     FTPhost               ftp1.reg365.net

     Host Directory     web

     Login                   buildingbids.ie

     Password               ****************

 
This works when i test it

 
     Testing Server

     Server Model               PHP MySQL

     Access                         FTP

     FTPhost               ftp1.reg365.net

     Host Directory     web

     Login                   buildingbids.ie

     Password               ****************

 
This works when i test it

 
     URL Prefix          http://ftp1.reg365.net

 
 
When i go to test the connection i get a message saying an unidentified error has occured.

 
My connbuildingbids code is

<?php
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_connbuildingbids = "mysql1.mylogin.ie";
$database_connbuildingbids = "buildingbids";
$username_connbuildingbids = "buildingbids";
$password_connbuildingbids = "*********";
$connbuildingbids = mysql_pconnect($hostname_connbuildingbids, $username_connbuildingbids, $password_connbuildingbids) or trigger_error(mysql_error(),E_USER_ERROR);
?>

 
My connection criteris is

Connection name     connbuildingbids

MySql Server          mysql1.mylogin.ie

Username               buildingbids

Password               *************

Database               buildingbids

 
Any help would be great thanks

I want to setup my PC so i can access this database through Dreamweaver but i don't know how to i have set up everything in DW as shown above but i know i need to assign the port and IP address and i dont know how to do this.  

I was also given this comment but i don't know what to do here.
If you are behind a firewall, or have firewall/anti-malware software on your computer, you may need to configure it to pass the requests from your client through!

Can someone help me
Thanks
Natasha
Comment
Watch Question

Commented:
assign port number and try whats the error

$hostname_connbuildingbids = "mysql1.mylogin.ie:3306";

Author

Commented:
Hi tried that and got same error unidentified error has occured i got a static IP address but i haven't put it anywhere as i dont know where to put it

Commented:
u can put either ip address or host name for
$hostname_connbuildingbids = "89.101.172.46";
try with port number as well if that doest work

Author

Commented:
same error using both

Commented:
>>"mysql1-remote.mylogin.ie" server from the 89.101.172.46 IP address as

they have granted access to host or to an ip address ? whats the ip address of  mysql1-remote.mylogin.ie ?

try with this:


<?php
$link = mysql_connect($hostname_connbuildingbids, $username_connbuildingbids, $password_connbuildingbids);
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

Open in new window

Author

Commented:
They have granted access to IP address and the address of mysql1-remote.mylogin.ie  is http://www.mysqladmin.ie/?server=1 dont know the IP.

I added you code to the connbuildingbids file and i still get the same error

Commented:
pls clarify
u are trying to connect to mysql database using php from an ip address 89.101.172.46. am i right ?
and your mysql database is in mysql1-remote.mylogin.ie. right ?

Commented:
Yes this is correct but i have not put the IP address anywhere. As in i have put in the same info into DW as i did before i got the IP address i am wondering do i need to put info somewhere elso on my PC ie the firewall i seem to have everything right in DW but i dont kno what else to do in my PC.

Commented:
firewall may be blocking it.

Commented:
so how do i unblock the firewall  

Commented:
just disable to firewall for the time being to know exact problem

Commented:
firewall turned off still get the same error

Author

Commented:
Hi

I have gone to a different server and now my code is like this

My connbuildingbids code is

<?php
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_connbuildingbids = "bono.hostireland.com";
$database_connbuildingbids = "buildingbids";
$username_connbuildingbids = "buildingbids";
$password_connbuildingbids = "*********";
$connbuildingbids = mysql_pconnect($hostname_connbuildingbids, $username_connbuildingbids, $password_connbuildingbids) or trigger_error(mysql_error(),E_USER_ERROR);
?>

 
My connection criteris is

Connection name     connbuildingbids

MySql Server          bono.hostireland.com

Username               buildingbids

Password               *************

Database               buildingbids


I get a different error now it says Mysql error #:1045  access denied for Buildingbids@localhost (Password:Yes)  so it looks like its looking locally for the database by default and i cant stop it.  I did orriginally have MySql set up on my pc and had done some test databases but i have deleted everything now even MySql but i still get this error so i am missing something.  Does anyone know why or how can i stop it defaulting locally. Thanks
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Commented:
Hi

I have remote access they have granted it to me through my static IP.  I put in the correct host name but it always defaults to localhost.  I think i need to clear port 3306 but i don't know how to do this.

Author

Commented:
Thanks
I have opted for a different way just using local host and editing it on their server there is a problem with my pc configuration thats not letting me gain access, but thanks for all your help.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.