We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Cannot connect to MSSQL on TCP 1433

Medium Priority
445 Views
Last Modified: 2015-01-05
osql -E fails, so then I tried to do telnet localhost 1433, and that fails as well.

No firewall in place.

A piece of custom software runs on this machine and is able to access MSSQL server.

My goal is to be able to run osql to do backups from a script.

How do I fix the osql / telnet 1433 connectivity problem?

Equipment: W2k3 SBS R2 Server (non-premium), SQL Server 2005 with Management Studio Express.
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2012

Author

Commented:
Actual SQL Server Info:
Microsoft SQL Server Management Studio Express                                    9.00.2047.00
Microsoft Data Access Components (MDAC)                                    2000.086.3959.00 (srv03_sp2_rtm.070216-1710)
Microsoft MSXML                                    2.6 3.0 4.0 6.0
Microsoft Internet Explorer                                    6.0.3790.3959
Microsoft .NET Framework                                    2.0.50727.1433
Operating System                                    5.2.3790
AneeshDatabase Consultant
CERTIFIED EXPERT
Top Expert 2009

Commented:
Hello DrDamnit,

Whats the Authentication ? if it is mixed mode, did u try it using
OSQL -u username -p password ?

Regards,

Aneesh
AneeshDatabase Consultant
CERTIFIED EXPERT
Top Expert 2009

Commented:
I am not sure whether sql 2005 supports OSQL, you have to use sqlcmd utility

Commented:
If the is SQL Server 2005 Express - TCP/IP is disabled by default.  You have to go in an enable TCP/IP before you can use that protocol to connect.
CERTIFIED EXPERT
Most Valuable Expert 2012

Author

Commented:
Mixed mode. Tried user / pass, no joy.
sqlcmd is giving me the same problem...probably because telnet cannot connect to it either.
wilje: Please confirm how I enable TCPIP.
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Commented:
You enable TCPIP in Surface Configuration

Commented:
You use the surface area configuration tool - navigate to the network section and enable TCP/IP.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.