Cannot connect to MSSQL on TCP 1433

osql -E fails, so then I tried to do telnet localhost 1433, and that fails as well.

No firewall in place.

A piece of custom software runs on this machine and is able to access MSSQL server.

My goal is to be able to run osql to do backups from a script.

How do I fix the osql / telnet 1433 connectivity problem?

Equipment: W2k3 SBS R2 Server (non-premium), SQL Server 2005 with Management Studio Express.
LVL 32
Who is Participating?

Improve company productivity with a Business Account.Sign Up

jmoss111Connect With a Mentor Commented:
hi Dr,

Why don't you just load up SQL Schedule from and let that do your backups? It's a free scheduler and works great with SQL Express
DrDamnitAuthor Commented:
Actual SQL Server Info:
Microsoft SQL Server Management Studio Express                                    9.00.2047.00
Microsoft Data Access Components (MDAC)                                    2000.086.3959.00 (srv03_sp2_rtm.070216-1710)
Microsoft MSXML                                    2.6 3.0 4.0 6.0
Microsoft Internet Explorer                                    6.0.3790.3959
Microsoft .NET Framework                                    2.0.50727.1433
Operating System                                    5.2.3790
Aneesh RetnakaranDatabase AdministratorCommented:
Hello DrDamnit,

Whats the Authentication ? if it is mixed mode, did u try it using
OSQL -u username -p password ?


What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

Aneesh RetnakaranDatabase AdministratorCommented:
I am not sure whether sql 2005 supports OSQL, you have to use sqlcmd utility
If the is SQL Server 2005 Express - TCP/IP is disabled by default.  You have to go in an enable TCP/IP before you can use that protocol to connect.
DrDamnitAuthor Commented:
Mixed mode. Tried user / pass, no joy.
sqlcmd is giving me the same problem...probably because telnet cannot connect to it either.
wilje: Please confirm how I enable TCPIP.
You enable TCPIP in Surface Configuration
You use the surface area configuration tool - navigate to the network section and enable TCP/IP.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.