I am on the EMAIL Blacklist

my ip address has been put on the email blacklist.  I am in the process of checking all staff computers for the cutwail2 spamBOT  that is being reported as infected on my network.

My questions is, according to CBL, i should "configure your NAT to prohibit connections to the Internet on port 25 except from real mail servers".

How do i do this with my NetGear FVS338?
dfisher68Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Look at the attached and add the Outbound rules - just change hte 10.0.0.2 IP for your internal IP Address of your mail server.
FVS338.jpg
0
etchy74Commented:
Basically what you want to do is prohibit all systems in your network from passing traffic over port 25 (SMTP) to the internet except for your mail server.

I took a quick look at the manual for your firewall ftp://downloads.netgear.com/files/FVS338_RM_28Feb09.pdf and it looks like you're going to need to create a couple rules.

The order of precedence matters as the packets are subjected to the rules in the order shown in the rules table, beginning from the top and proceeding to the bottom.  Therefore you're going to need to put in a rule that blocks all SMTP traffic from your LAN to the internet.  You're also going to need a rule that allows SMTP traffic coming from the IP address of your mail server.  The allow rule for your mail server should reside above the block rule so it will get processed first.

This will allow your mail server to send to the internet, but any computers that are infested with a virus will be unable to send.  There are some visual examples in the manual linked above under Chapter 4:  Setting LAN WAN Rules
0
etchy74Commented:
Looking at alan's example above I might have misread the order that the rules get processed...
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Alan HardistyCo-OwnerCommented:
My info is slightly wrong - in the first SMTP block - don't add all IP's create a range that misses out your server - just done this on mine and it blocks the flow if you block all.  Sorry.
This one works

FVS338.jpg
0
Alan HardistyCo-OwnerCommented:
If you set the default outbound policy to block, make sure you add other allow policies such as DNS, POP3, IMAP, HTTP, HTTPS etc if you use those services.
0
dfisher68Author Commented:
thanks to both of you.  i added the rules and email is still flowing, so thats good.  Now i just need all the field staff to get their computers updated and scanned.  
0
Alan HardistyCo-OwnerCommented:
Follow xmachines's advice on the following link - wireshark will be your best friend!
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24463550.html?cid=238#a24606079 
0
Alan HardistyCo-OwnerCommented:
Malwarebytes (www.malwarebytes.org) may also help you out here.  It is free and a darn good tool.
Combofix is another - http://www.bleepingcomputer.com/combofix/how-to-use-combofix
0
dfisher68Author Commented:
alan - i set the rule before seeing your response about creating a "block range" and email seems to be working.
0
Alan HardistyCo-OwnerCommented:
Is the default policy for outbound set to Allow or Block.  If it is set to Allow - the rule will have no effect.  Set the default outbound to Block and then add other allow rules for other protocols:
My latest screenshot of my firewall

FVS338.jpg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alan HardistyCo-OwnerCommented:
You can restrict the other protocols if you wish to the server only exactly or as you need.
0
dfisher68Author Commented:
IMAP4 is not in my list of services, what port do i use if i need to enter it manually.  Also, i have two emails i use, one is the work exchange and one is my comcast account.  I added the rules above (after setting default to block) and now my comcast email cant send and receive - i have outlook configured to use comcast on one of my computers.

as for all the other advice on the sniffers and removing the virus, thank you all.  I have some work to do.
0
Alan HardistyCo-OwnerCommented:
IMAP4 is port 143 in case you need to add the service.
The comcast won't sent now because you blocked it.  If you need to send out email via SMTP on your computer, you have to allow it through the firewall now.  Modify the block for SMTP (might have to create another rule to start after your IP) and adjust the existing block to stop before your IP.  Then add an allow for your IP only, but make sure you are not the infected computer first!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.