• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1848
  • Last Modified:

Activesync Error With FolderSync

Any ideas as to how to resolve this little niggle I have?  It is not a show stopper - Activesync works, I would just like to tie up a loose end.

Report from https://testexchangeconnectivity.com

Attempting an Activesync session with server
  Errors were encountered while testing the ActiveSync session
 Test Steps
   Attempting to send OPTIONS command to server
  OPTIONS response was successfully received and is valid
 Additional Details
  Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Fri, 10 Jul 2009 14:23:16 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

 
 
 Attempting FolderSync command on ActiveSync session
  FolderSync command test failed
 Additional Details
  An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body is: <body><h2>HTTP/1.1 403 Forbidden</h2></body>
0
Alan Hardisty
Asked:
Alan Hardisty
  • 9
  • 6
  • 3
  • +1
1 Solution
 
XCHExpertCommented:
Your Exchange server is E2k3 but when I see the ActiveSync file verison . it is old. Though it's working at your end. you can choose upgrading it to either 6.5.7654 or more.

403 says access issue but since its working you might not have selected SSL option while checking thru test .
0
 
Alan HardistyCo-OwnerAuthor Commented:
Did not test SSL as I use a self-signed cert and it always fails that part.
Checking for an update now - thanks.
Alan
0
 
Alan HardistyCo-OwnerAuthor Commented:
I placed an SSL cert on the Website and it gets past the SSL stage but still fails at the same place.
Any suggestions?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
XCHExpertCommented:
0
 
Alan HardistyCo-OwnerAuthor Commented:
Neither are applicable I'm afraid - not requiring SSL on the Exchange Virtual Directory or using Forms Based Authentication.
Sorry.
0
 
XCHExpertCommented:
The cert you are using is for accessing OWA and ActiveSync right ?
0
 
Alan HardistyCo-OwnerAuthor Commented:
Yes - It is happy with the cert.
0
 
SubsunCommented:
0
 
SubsunCommented:
If not, are you using ISA?
0
 
Alan HardistyCo-OwnerAuthor Commented:
Hi subsun - thanks for your comments.
All devices sync happily - WM5, WM6, WM6.1 and iPhones and the Box is not SBS - I would just like to know why / eliminate the 403 error when running the testexchangeconnectivity tests as I don't understand why the sync works 100% but yet the test fails.  All info so far has brought up nothing relevant.
It is not a showstopper and if I don't clear up the issue, I won't lose sleep - but I like to see things working 100% and would love to have a clean test just for peace of mind.
I ran another test from another site (https://store.accessmylan.com/main/diagnostic-tools) which resulted in it telling me that Activesync was either not enabled for my user account, or for the organisation.
So clearly there is something a little confusing going on and that it what I would like to get to the bottom of (if I can).
0
 
SubsunCommented:
Not sure about the real cause.Your build (6.5.7638.1) looks like your server need updates, hope you have already run the ExBPA. Another thought, I have seen "forbidden response" comes when you have multiple IP's in your exchange servers and you have configured the Default web site IP address to all assigned.
0
 
Alan HardistyCo-OwnerAuthor Commented:
The server is patched as far as it can be - no downloads available and I just checked Microsoft's Web and nothing new there either.
I have run the Exchange BPA but nothing obvious there.
IP address is all unassigned.
0
 
SubsunCommented:
Hmm& Weird.
Is unsupported devices enabled? If not enable it and test.
If you have enabled the device security settings, add your account in exceptions and test.
0
 
Alan HardistyCo-OwnerAuthor Commented:
Yes - unsupported devices is enabled.
Added to exceptions and tested........
BINGO!
Clean report.  WTF?
Any thoughts as to why adding to the exceptions causes it to work happily?
 
0
 
Alan HardistyCo-OwnerAuthor Commented:
Okay - solved the last question.  I removed my self from the exception list, then went into localhost/mobileadmin on the server and removed some old devices that included a WM5 device.
Re-ran the test and all happy.
Subsun - you are a star.  Thanks very much.
0
 
Alan HardistyCo-OwnerAuthor Commented:
Thanks a million Subsun - I knew there had to be a reason for the error and I am grateful for your assistance.  Alan
0
 
SubsunCommented:
I Guess& When you access the active sync first time the server will enforce the security policy to device and the website unable to simulate the situation, so the server not allowing website to do the FolderSync test.
0
 
ActiveStinksCommented:
Well done Subsun, you answer was welcome after hours and hours of searching.
0
 
SubsunCommented:
Happy to help :-)
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 9
  • 6
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now