Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 300
  • Last Modified:

HTTPS does not work internally but works externally after a new website is launched

My client just launched a new website to replace the old one. Externally the website works fine. We had to change the DNS entries on the server for it to work internally. However, HTTPS still does not work internally. Everything else does. I'm assuming I have to make some changes to get HTTPS to point to the correct IP. But I can't find anything on how to do so. Any help is appreciated!
Thanks!
0
swinger22
Asked:
swinger22
  • 2
1 Solution
 
Jan SpringerCommented:
The certificate is tied to the host name.

1) has the host name of the secure web server changed (www.domain.com)?
2) is any firewall blocking TCP port 443 to that IP?
0
 
swinger22Author Commented:
The host name of the secure webserver has not changed, only the IP has. I can't find anything that indicates that port 443 is blocked to the new IP.
0
 
gikkelCommented:
Are you connecting to https://[i]servername.domainname[/i].[b]local[/b]/exchange when connecting internally?  Can you connect to companyweb?  
0
 
Jan SpringerCommented:
If the web site was moved internally behind the same firewall that you sit, you may be running into a hairpin problem (traffic going out and coming back in the same public firewall interface).

Find out if your firewall supports DNS doctoring.  Some firewalls will allow that configuration option to provide the internal IP address of the web server instead of the external (public) IP.

If that's not an option, perhaps the firewall can be configured to allow hairpin traffic.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now