Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

OWA not working externally after changing the router to a CISCO 877

Posted on 2009-07-10
6
Medium Priority
?
651 Views
Last Modified: 2013-11-16
Hi, I recently changed our router to a cisco 877, the exchange/owa Server and port used have not changed. I added the NAT and acl for owa to the new router. all other NAT and ACL are working fine and are similar to my OWA entry. I've checked IIS /exchweb and made sure to uncheck SSL. I am not using the defauilt port. This is set to 8081.

ip nat inside source static tcp xxx.xxx.xxx.7 interface Dialer0 8081
.
.
.

access-list 101 permit ip any host xxx.xxx.xxx.7
access-list 101 permit tcp any any eq www
access-list 101 permit tcp any any eq 22
access-list 101 permit tcp any any eq 8081

Has anybody experienced this issue berfore? any comments/suggestions greatly accepted. NAT and ACL also included in CODE: section
ip http server
ip http access-class 2
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp xxx.xxx.xxx.7 interface Dialer0 25
ip nat inside source static tcp xxx.xxx.xxx.6 interface Dialer0 21
ip nat inside source static tcp xxx.xxx.xxx.6 interface Dialer0 80
ip nat inside source static tcp xxx.xxx.xxx.6 interface Dialer0 22
ip nat inside source static tcp xxx.xxx.xxx.7 interface Dialer0 8081
ip nat inside source static tcp xxx.xxx.xxx.19 80 xxx.xxx.xxx.xxx 80 extendable
!
ip access-list extended SDM_AH
 remark SDM_ACL Category=1
 permit ahp any any
ip access-list extended SDM_ESP
 remark SDM_ACL Category=1
 permit esp any any
ip access-list extended SDM_IP
 remark SDM_ACL Category=1
 permit ip any any
ip access-list extended SSH
 remark SDM_ACL Category=128
 permit ip any host xxx.xxx.xxx.6
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit xxx.xxx.xxx.xxx 0.0.0.255
access-list 2 remark HTTP Access-class list
access-list 2 remark SDM_ACL Category=1
access-list 2 permit xxx.xxx.xxx.xxx 0.0.0.255
access-list 2 deny   any
access-list 100 remark SDM_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 101 remark SDM_ACL Category=0
access-list 101 permit ip any host xxx.xxx.xxx.7
access-list 101 permit tcp any any eq www
access-list 101 permit tcp any any eq 22
access-list 101 permit tcp any any eq 8081
****** I added today to see if it would make any difference **********
access-list 101 permit tcp any host xxx.xxx.xxx.xxx eq 8081
********************************************************************************
access-list 102 remark SDM_ACL Category=0
access-list 102 permit ip any host xxx.xxx.xxx.6
access-list 102 permit ip any host xxx.xxx.xxx.19
access-list 103 remark SDM_ACL Category=0
access-list 103 permit ip any host xxx.xxx.xxx.7
access-list 104 remark VTY Access-class list
access-list 104 remark SDM_ACL Category=1
access-list 104 permit ip xxx.xxx.xxx.xxx 0.0.0.255 any
access-list 104 deny   ip any any

Open in new window

0
Comment
Question by:Blondzer
  • 3
  • 2
6 Comments
 
LVL 65

Expert Comment

by:Mestha
ID: 24825190
OWA doesn't like using other ports. I have never had much success on using a port other than 80 and 443. If you want to use any other feature like RPC over HTTPS, or Exchange ActiveSync then you must use the native port as they are hard coded to those ports.

Simon.
0
 
LVL 8

Accepted Solution

by:
Npatang earned 1500 total points
ID: 24825229
if you try to browse OWA other then the defualt ports you need to mentiond the same port with the URL while browsing OWA in browser
0
 

Author Comment

by:Blondzer
ID: 24825333
Thanks guy's
I can telnet to port 8081 internally but not externally.
We use the url http://xxx.xxx.xxx.7:8081/exchange. Works ok internally.
same format when using the external IP address. I think it would be a ACL issue?
0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 

Author Comment

by:Blondzer
ID: 24825726
I have it working now. I think your right about using other than default. I added another public IP address to the router and changed OWA to use the default. Worked straight away. still confused why it worked with the old router.... :-)
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24825780
Thats the default behaviour ...Anyways Now you know whats happening and how to browse it ?
0
 

Author Comment

by:Blondzer
ID: 24826040
sorry Mestha:I meant to split the points!!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses
Course of the Month9 days, 15 hours left to enroll

927 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question