Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1520
  • Last Modified:

RPC over HTTP issue

We recently lost RPC over HTTP connectivity. I have been troubleshooting this for the last few days following the MS Troubleshooting guide but was unable to find any problems.
I have just managed to restore connectivity by ticking 'Windows Integrated Authentication' in the Directory Security tab of the rpc site Properties.  All other settings left as recommended (ie Basic Authentication also ticked, anonymous access disabled). Basic Authentication is also set on the client machines.
I presume this points to some kind of security problem, but can find no issues with our certificate (GoDaddy) or other security settings.
Hopefully the fact that enabling Windows Integrated Authentication fixes the issue might give someone who understands this better a clue?
0
keithxp
Asked:
keithxp
  • 3
  • 2
1 Solution
 
mojopojoCommented:
If you are running SBS 2003 and "lost RPC over HTTP" (means it was working fine and then stopped) that generally suggests a change in your network, ISP or firewall.

First thing in SBS 2003 is to re-run the CEICW wizard from Computer Management and select the proper connection OWA, RWP, etc. ( http://support.microsoft.com/kb/825763 ) That will fix 90% of all SBS 2003 connectivity issues.



0
 
keithxpAuthor Commented:
Thanks for the suggestion, I should probably have mentioned that I have re-run the wizard a couple of times without luck.
0
 
Rick_LewisCommented:
Your right to tick windows authentication in rpc and make sure your domain is displayed in the default domain box. I always setup the clients thus:

https://remote.yourdoamin.com
Connect using SSL only (Ticked)
Only connect to proxy... (ticked)
msstd:remote.yourdomain.com

On fast networks... (unticked)
On Slow Networks (ticked)

Proxy Authentication set to NTLM Authencation

Additionally, I've found that occasionally the windows authentication and or basic authentication in rpc security gets unticked no idea why, but it does. Just double check your firewall on your router for the usual ports allowed (80,443)
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
keithxpAuthor Commented:
Hi,
well that configuration seems to be working for me too, but am I going mad or do most guides recommend that the RPC virtual directory security settings are that
- anonymous access is disabled
- only Basic Authentication is ticked
- SSL is enabled
??
At present clients are using Basic Authentication, but you are suggesting it is better to set it to NTLM (presumably to match to the Basic Authentication by NTLM on the virtual directory)?
 
0
 
Rick_LewisCommented:
Yes, in my experience using NTLM also enables the remember password box to work on the clients outlook. Especially when the PC's are not joined to the domain. As for guides, well I've read quite a few too but after 6 years of working on SBS2003 this works just fine.
0
 
keithxpAuthor Commented:
OK. This is great because I have lost RPC-HTTP connectivity several times in the past, never understood why (ie could not relate it to a particular change on the server etc). Hopefully I can fix it quicker in future. thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now