registering with dns

when a client connects via vpn with their laptop from home, they get a 10.10.50.x address from the cisco asa dhcp server.  everything works fine.  ok.  they come into the office and plug into the network, and get a new address - 10.10.10.x or 10.10.20.x..

ok, the problem is that the dns server still has the 10.10.50.x address.  i have set the scavenging/aging down to 12 hours for the refresh interval, and 12 days for the non-refresh... the defaul is 7 days for each.

in order to resolve this, i have to delete the A record and do an ipconfig /registerdns in order for the dns server to update the database with the new ip address.

any idea how i can fix this problem?
Who is Participating?
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

First things first, the 12 hours refresh: I know why you've set it, but it'll cause you problems.

Your servers, and everything else with static IP addressing only Refresh once every 24 hours. If any miss the chance the record will be removed as Stale. Because of the long no-refresh you won't bump into this often, but when you do I'd say it'll be quite irritating. Also depends on your Scavenging Period, but eventually it'll get lucky.

In your situation I would head to the DHCP server, turn off dynamic updates there and let the client deal with it (unless you have pre-Windows 2000 stuff this won't be a problem). It'll take a while to swap over, the security on the existing records is all wrong for client update, but it'll get there eventually.

Update requests (when a client changes IP) will always be allowed, even during No-Refresh.

If you're after more specific Refresh / No-Refresh intervals it tends to be best to set No-Refresh + Refresh to match the Renewal Interval of DHCP (half the lease duration), avoiding values less than 24 hours for the Refresh for the reasons above.

For example, a 20 day DHCP lease works well with 5 days No-Refresh and 5 Days Refresh.

cmournAuthor Commented:
ok, i have turned off dynamic updating on the dhcp server, so that the client can handle updating dns.  i change the refresh interval to 24 hours, and the non-refresh to 3 days.  the lease period is 6 days.  we'll see how this works.  thanks for the feedback.... will report back shortly...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.