WinXP forgets to turn off monitor.

I have a Windows XP system that always forgets to turn of the monitor.  

In Display Properties/ Screen Saver/ Power/ Power Schemes I set "Turn off monitor" to any value from the pull-down list (lets say 5 mins).  Click OK twice.  Five minutes later, the monitors will blank exactly as desired, and come back on with a key press or a mouse movement.  This will continue to work an indeterminate number of times.

But sometime that same day it will stop working, and the monitors will remain on.  It never starts working again by itself.  If I return to the Power Scheme the monitor box is still set as above (it remembers the setting, even though not working.)  If I change the setting, say to 10 mins. and click OK, then it will start working again -- for a while.  

So Windows is not forgetting my power settings -- it is forgetting to apply them.  What service or driver has that task?  Anybody seen this problem & fixed it?

LVL 1
yahoolaneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gsnshankarCommented:
Do u have any screensaver or power management utility running?
0
yahoolaneAuthor Commented:
Screensaver is set to None.  There is no external power management software -- just Windows.  This is the default 'Always On' power scheme, with only the 'Turn monitor off' setting changed.  The other three settings (HD, Standby, Hibernate) are set to 'Never'.

The system runs several background programs I wrote (in Delphi) that I want running continuously, including overnight.  So I don't want it to power down.  I just want the screen to blank.  

This is an Intel Q6600 Core2 Quad @3.6GHz, 4Gb RAM, Nvidia GeForce 9500GT video adapter with two LCD monitors attached.  However, the problem does not go away when I put in different Nvidia cards.  It could be due to Nvidia drivers, but it's not the hardware.  The video driver says Nvidia 12/26/2008  v6.14.11.8120.  

I will try updating the video drivers.

The ACPI driver is the default Microsoft ACPI Multiprocessor PC, dated 7/1/2001, v5.1.2600.  It seems to me that this would be the process responsible for blanking the screen.

0
yahoolaneAuthor Commented:
Installed latest Nvidia drivers.  No change.  Still forgets.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

yahoolaneAuthor Commented:
Does anyone know of any settings or files that would affect screen blanking?

I'd like to try making changes just to see if it has any effect.  
Are there any registry entries?
Is this handled by the ACPI driver?  Some other driver or dll?
What process is responsible for scheduling screen blanking/standby/hibernation?

Where should I look for detailed info about this?  
Is there a Windows API for changing Power Saving settings?

0
SJH01Commented:
In device manager, is Monitor driver "Default Monitor" or "Plug and Play Monitor"?
0
BitsBytesandMoreCommented:
yahoolane,
What is happening to you is very typical of with WinXP when you leave an application open on the desktop. It's a known bug with XP and some applications and has been semi-corrected in SP3 .
Try updating your XP to SP3 if you have not already  done so. Test. Make sure you do not leave any open applications on the desktop.
If it persists, try disabling your Startup items for testing purpouses. To do this go to Start-Run and type msconfig. The system configuration utility will popup. Click on the "Selective Startup" and uncheck the "Load Startup Items". Test.
If the above works and the problem disappears, you will need to go into the msconfig again but this time go to the Startup TAB. Start by selecting aproximately half of the items and leave the other half unchecked. Test. If it still works, repeat the process you just did: select half of the remaining unselected items and test again. At some point you will find which item is the one that is interfering with the monitor shutdown.
I am of course assuming that you have already scanned your computer for viruses and spywares and that you have run other system diagnostics like checking your hard drive(s) and your memory.
Let me know if the above helps.
 
 
0
yahoolaneAuthor Commented:
SJH01,
The monitor is "Plug and Play Monitor".

BitsBytesandMore,
This machine is not at SP3.  When SP3 came out I tried to update it, and the update failed.  I'll try again.

Yes, there are always apps running on this machine.  That's why I don't want it to sleep or hybernate.  I just want the monitors to turn off.

When you say "application open on the desktop", do you mean its window visible, or just running, with icon showing on the taskbar?  Assuming the first, it does not help to minimize all windows (show desktop), after the problem shows up.  I don't know if that would help before the problem appears, but it would be very inconvenient.  I'd be better off with a button that turned off the monitors.

Yes, the system is virus scanned, checkdisked, etc.

Sounds like SP3 might contain the problem.  Is there a Microsoft HotFix or KB page for this problem?  Most things in the service packs appear in one of those first.


0
BitsBytesandMoreCommented:
Ok..... let me try to address your questions in some sort of order.
Usually, not always, if you minimize the applications, the monitor will shutdown.
Make sure that you have the right driver for the monitor. I understand you mentioned it is PnP but what Windows "thinks" the monitor is not necessarilly what the monitor really is. See if you can find a driver at the manufacturers website or if a driver came with the monitor when you purchased it.
If your system is not taking SP3 it's because something has a problem (this might be part of the monitor problem). Go to the Microsoft website and try following their troubleshooting procedures for installing SP3.
http://support.microsoft.com/kb/950717
Otherwise call Microsoft and they will give you free support for installing the Sp3.
Definitely you would be better off just turning off the monitor manually but then you would would miss out on the fun of fixing it. lol....No, really....there seems to be another problem and the monitor issue is just the "tip of the Iceberg".... In my opinion, you should address this....
 
 
 
 
0
BitsBytesandMoreCommented:
By the way.....lol......it's not that Windows "forgets" to turn the monitor off. What's happening is that some process is interfering with the monitor shutdown....ie: some application is not working correctly and it hangs so the system cannot process the order to shutdown the monitor....check the event log to see what errors it's documenting:
Right click on "My Computer" - Click on manage and then select the Event Viewer and select the Application and the System entries and see if you see any errors that might be causing the monitor to no shutdown.
0
ekincamCommented:
The registry entries are at HKCU\ControlPanel\PowerCFG.  Here you'll find an entry that describes the current power policy indicated by a number.  Then go to PowerPolicies and open the numbered folder that corresponds to the power policy number above.  In there, you'll find an entry that has a long string of hex values.

Item 1C and 1D corresponds to standby, 38 and 39 correspond to screen power off, and 40 and 41 are HDD off.  All these are in seconds and then reversed.  So for example, you want monitor off in 20 minutes that is 20* 60=1200 seconds.  In hex, that value is 4B0.  In position 38, you would put B0 and then in position 39 you put 04.  

If there are no users logged in, XP uses the default user values which are located in:
HKU\.default\ControlPanel\PowerCFG
0
yahoolaneAuthor Commented:
BitsBytesandMore,

Actually, "Windows forgets" appears to be a better description of what's happening than "some application is not working correctly".  Once the screen blanking stops working, it doesn't matter if anything is running or not.  Windows will not restart screen blanking until I change the time value for turning off the monitor.  

It could be that some application is causing Windows stop blanking.  But it's not as simple as an application actively *preventing* Windows from blanking.

Looking in the Event Viewer is a good suggestion.  Of course, there's nothing there saying "I'm doing it", but PerfectDisk defragmenter is complaining about something, so I'll look into that.

ekincam,

Thanks for the registry info.  I've verified that this is not caused by anything changing the registry settings.  They remain unchanged when screen blanking stops working.  

Very odd that simply changing the time value for blanking makes it work again.  I had thought all that would do is change the registry setting.  Apparently it's doing more than that.  I will experiment with changing those settings by hand after blanking fails.  I'm also changing the default and global settings to blank after 20 min., just in case what's happening is Windows switching from my User setting to the default.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.