Solved

Trunking two network cards on Ubuntu Server 9.04

Posted on 2009-07-10
9
1,574 Views
Last Modified: 2013-11-15
I'm trying to trunk two network cards together. I have three network cards in this server; eth0 is onboard, and eth1/eth2 is meant to be trunked. I have a test lab setup at the moment with almost an identical setup on a computer as the server has.

I found a website explaining how to do this and for the most part it makes sense but theres still a few unanswered questions. Here's a link: http://emcken.dk/weblog/archives/274-trunk-port-in-vmware-used-by-ubuntu-server-hardy.html

I followed this and here's what my config file looks like:
auto eth1.2
iface eth1.2 inet static
        address 192.168.1.6
        netmask 255.255.255.0

My question is how does the computer know that I would like to trunk eth1 & eth2 and leave eth0 out of it?
0
Comment
Question by:supanatural
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 8

Expert Comment

by:LunarNRG
ID: 24827228
I'm not 100% sure, but the instructions at the link you provided, seem to be doing the _inverse_ of what you actually want. In other words, instead of trunking(/bonding) two nics, they seem to be assigning another ip address to the same nic.

These instructions are a little old, but they should get you where you want to go ...
http://www.howtoforge.com/network_bonding_ubuntu_6.10



0
 

Author Comment

by:supanatural
ID: 24827381
The problem is that that's ubuntu 6.04. I don't know if it has changed a lot since then. I'm running 9.04.

When I use the setup:
auto eth1.2
iface eth1.2 inet static
        address 192.168.1.6
        netmask 255.255.255.0
auto eth2.2
iface eth2.2 inet static
        address 192.168.1.6
        netmask 255.255.255.0

It doesn't work. It does work if I disable trunking on my switch which is weird.
0
 
LVL 8

Expert Comment

by:LunarNRG
ID: 24827469
Actually the instructions are for ubuntu 6.10, and I doubt that bonding config has changed all that much. FWIW, I used these instructions to bond nics w/ a debian server just a few months ago.

Good Luck!
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 8

Accepted Solution

by:
LunarNRG earned 500 total points
ID: 24827497
0
 

Author Comment

by:supanatural
ID: 24827548
I'm having a problem with these instructions. I posted the steps in the code snippet that I'm having a hard time with. In /etc/modprob.d, I have 5 files that start with the word blacklist and thats it.

Also, I'm running x64 architecture if that helps
1. Now append the following items to your aliases file:
 
pico /etc/modprob.d/aliases
 
2. Next, append the following items to your i386 file:
 
pico /etc/modprob.d/arch/i386

Open in new window

0
 

Author Comment

by:supanatural
ID: 24827642
I like that article. I'm still having the same problem though with: /etc/modprobe.d/arch/i386

Here's all the files i see when I go to that folder:
root@Hypervisor2:/etc/modprobe.d# ls
blacklist-ath_pci.conf      
blacklist-firewire.conf
blacklist-watchdog.conf
blacklist.conf
blacklist-framebuffer.conf  

Open in new window

0
 
LVL 8

Assisted Solution

by:LunarNRG
LunarNRG earned 500 total points
ID: 24827689
I'm pretty sure you can just create a file in /etc/modprobe.d and include the directives alluded to in the instructions. I don't think the name of the file matters, but it should have the .conf extension, or so it seems.

See also, http://ubuntuforums.org/showthread.php?t=1147741
0
 

Author Comment

by:supanatural
ID: 24827850
Cool, I have it working (sort of). When port trunking is disabled on my switch, it works, but when port trunking is enabled on my switch it stops working. Is that normal? Is there a way to test that I do infact have a 2gb line working?
0
 
LVL 8

Expert Comment

by:LunarNRG
ID: 24828657
"""
When port trunking is disabled on my switch, it works, but when port trunking is enabled on my switch it stops working. Is that normal?
"""
I don't know. But, I'd kind of expect the opposite.

Can you elaborate on what you mean by "it stops working"? dead link?

If you post the make/model of your switch, we can have a look at the manual. While you're at it, post the result of 'cat /proc/net/bonding/bond0' (replace bond0 with the name you gave the bonded interface, if different).

"""
Is there a way to test that I do infact have a 2gb line working?
"""

I didn't need to bond for performance, so it's unfamiliar territory. But in this case, you may find these articles more your ... um, er ... 'speed', and suggest testing with the iperf package ... seems reasonable.

http://www.enterprisenetworkingplanet.com/nethub/article.php/3696561
http://www.enterprisenetworkingplanet.com/nethub/article.php/3697756


0

Featured Post

Learn by Doing. Anytime. Anywhere.

Do you like to learn by doing?
Our labs and exercises give you the chance to do just that: Learn by performing actions on real environments.

Hands-on, scenario-based labs give you experience on real environments provided by us so you don't have to worry about breaking anything.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question