PSEXEC access denied when using @file for multiple computers

I am attempting to use PSEXEC to deploy and MSP (Microsoft Installer Patch) file to about 80 computers. For some reason when I try to put the command in a batch file I get a logon failure on the remote computer. Below is the string from the batch file:

C:\PSTools\psexec \\@C:\PSTools\CPUListHPPC.txt -u "Domain\administrator" -p "PassWord" msiexec.exe /p "\\eoverbylt\osc\OSCC70R3G02Client.msp" /qn >deployhppc.log 2>&1

The funny thing is if I just open a command prompt and just run the command from there it works flawless.

So to explain the command.  PSexec is reading a list of computers from CPUListHPPC.txt and using the domain administrator account to log into the pc.  Then uses the /p switch to install the MSP (patch) file to the program with /qn or quiet mode enabled and logging to deployhppc.log file.

Is psexec ignoring the -u and -p switches for the username/password since it is being opened via a batch file?
Who is Participating?
evan021702Connect With a Mentor Author Commented:
Deployed using the command instead of the batch file.  I believe there is a problem with PSExec when trying to run at a bat.  Here is a quick walkthrough on what I did:  
evan021702Author Commented:
Just for point of fact.  If you are looking to deploy to multiple PCs and don't want to wait on interactive messages from each PC.  You can use the -d switch to have the command simply continue to the next PC once the remote install process is started on each PC.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.