?
Solved

How to create a SIte to Site VPN between two ASA 5505

Posted on 2009-07-10
8
Medium Priority
?
2,883 Views
Last Modified: 2012-06-11
HI,
I am trying to setup a site to Site VPN between two Cisco ASA 5505's.  I am using ASDM 6.21 and ASA version is 8.2.1 on both firewalls.  These are two firewalls are in a lab environment and are connected together via a cross over cable (which could be the problem right there although with every change I use an straight through cable just to be sure).  I am not sure if I need some sort of switch in between the two or not.  Anyway, here are the details:

Server A is connected to Firewall A via CAT5 cable.  Connection is good, I can run the ASDM.  The inside network is 192.168.1.0/24.  The IP address on the outside port of the Firewall is 207.148.48.100.

Server B is connect to Firewall B via CAT5 cable.  Connection is good, I can run the ASDM.  The inside network is 192.168.2.0/24.  The IP address on the outside port of the Firewall is 76.9.51.40.

I connect Firewall A and Firewall B via a cross over cable on the default outside interface (VLAN1 Port 0).  Remember I have used a straight through just in case with every change.  

Onto the GUI.  

1. I start up the VPN Wizard on Firewall A and select Site to Site.  I enter the Peer IP Address as 76.9.51.40, select the Pre shared key and enter the text "test" then click next

2.I use the default IKE encryption (3DES, SHA, 2) and then next

3.I use the default IPSEC encryption (3DES, SHA, 1) and then next

4. I select "Protect" as the action.  For Local Network I select the inside network.  For the remote Network I type in 192.168.2.0/24.  I leave the box checked at the bottom where is asks "Exempt ASA side host/network from address translation" with the drop down box as "inside" and click next

5.Click Finish.


This what I do for the GUI on Firewall B

1. I start up the VPN Wizard on Firewall B and select Site to Site.  I enter the Peer IP Address as 207.148.48.100, select the Pre shared key and enter the text "test" then click next

2 .I use the default IKE encryption (3DES, SHA, 2) and then next

3.I use the default IPSEC encryption (3DES, SHA, 1) and then next

4. I select "Protect" as the action.  For Local Network I select the inside network.  For the remote Network I type in 192.168.1.0/24.  I leave the box checked at the bottom where is asks "Exempt ASA side host/network from address translation" with the drop down box as "inside" and click next

5.Click Finish.

The VPN does not work.  A co-worker has created a VPN with an ASA 5505 before and said it cannot be done with the GUI itself.  He said that he had to add three lines in the CLI.  I am trying my best to see if he is wrong, that is why I ask not to solve this problem using the CLI. I want to do it using rthe GUI unless it is impossible without a doubt.

Thanks.  
0
Comment
Question by:MaltusW
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 24828139
HI,

Please provide meg the config files!

Thanks,
Istvan
0
 

Author Comment

by:MaltusW
ID: 24828238
No Problem.  

Here is the config for Firewall A

ASA Version 8.2(1)
!
hostname Firewall-A
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 207.148.48.100 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa821-k8.bin
ftp mode passive
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 76.9.51.40
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 76.9.51.40 type ipsec-l2l
tunnel-group 76.9.51.40 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8fafea4f0f2c50e4ec26c317c8d29916
: end

Here is the config for Firewall B

ASA Version 8.2(1)
!
hostname Firewall-B
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 76.9.51.40 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa821-k8.bin
ftp mode passive
access-list outside_1_cryptomap extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 207.148.48.125
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.5-192.168.2.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 207.148.48.125 type ipsec-l2l
tunnel-group 207.148.48.125 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:53a2f9205021ea44a7f6533b6517d71b
: end



I am taking off from work for the weekend guys, although I will probably pull some OT on Sunday.  This isn't a rush yet, but I appreciate any answers.  I will try to answer any questions from home though.

Thanks.


0
 
LVL 57

Expert Comment

by:Pete Long
ID: 24829934
Full runthrough - http://www.petenetlive.com/Tech/Firewalls/Cisco/s2svpn.htm
>>A co-worker has created a VPN with an ASA 5505 before and said it cannot be done with the GUI itself.
Thats not true - however in some cases you need to manaully allow traffic
access-list outbound permit ip {lan behind ASA} {subnet behind ASA} {LAN behind distant ASA} {subnet behind distant ASA}
access-list outbound permit ip any any
access-group outbound in interface inside
 
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 24829973
HI,

Please provide me the following booth sides:
sh cry isa sa
sh cry ipsec sa

Thanks,
Istvan
0
 

Author Comment

by:MaltusW
ID: 24836543
sh cry isa sa
There are no isakmp  sas

sh cry ipsec sa
There are no ipsec  sas

It is exact same for Firewall A and also Firewall B
0
 

Author Comment

by:MaltusW
ID: 24836565
So Pete,
If I have to manually add those lines via the CLI then VPN Wizard is not really doing its job.  Could I add those lines in the GUI interface under the Configuration Tab --> Firewall --> add access rule?  

Thanks.
0
 

Accepted Solution

by:
MaltusW earned 0 total points
ID: 24864870
Well, I figured out the problem, and by telling you what it is was I will be admitting to how much I don't know about Cisco.  Oh well, you have to start somewhere and my company is paying me for the ICND 1 and 2 courses.

There was no static default route going to the outside port.  Basically just this command on both routers although I did it via the GUI

route outside 0.0.0.0 0.0.0.0 <outside_interface_ip_address_goes_here> 1      

Thanks everyone.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 32644791
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question