Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

XP "Always do the selected action" not working.

Posted on 2009-07-10
7
Medium Priority
?
681 Views
Last Modified: 2012-05-07
A friend asked me to help with what I thought would be a simple fix -- just run one of the many AutoPlay repair tools (e.g. Kelly's Korner).     But nothing I've tried is working.

Details:    Inserting a DVD in the drive results in the typical pop up listing the various possibilities ... which include "Play with PowerDVD" and "Play with Windows Media Player".     Selecting one of these works fine.    But if you check the "Always do the selected action" box it has NO effect ==> the next time you insert a DVD you get the same choice menu (with the "Always do ..." box already checked).

If you do a Properties on the drive and go to the AutoPlay tab, select DVD movie, click the "Select an action to perform",  highlight a choice (e.g. play with PowerDVD), and click Apply -- the result is the same !!   No change.    Going back to the drive's properties always shows the "Prompt me each time to choose an action" box checked !!

As I noted, I've tried several common registry mods; and run several "AutoPlay fix" utilities -- NOTHING changes this behavior !!      Any ideas???

I'm NOT looking for "Googled" links -- I've already done that & tried anything that sounds plausible.     Looking for someone who's experienced this exact issue and found a fix !!

System is XP SP3 with all updates.

Points doubled to 500 for a focused, correct, works-first-time answer :-)
0
Comment
Question by:garycase
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 9

Expert Comment

by:nick2253
ID: 24828537
Does the action hold when you insert the same DVD?  ie, you run a movie, say the Lion King, and you select remember this response for PowerDVD.  Then, you re-insert the Lion King.  Does it pop up again?

--Nick
0
 
LVL 70

Author Comment

by:garycase
ID: 24828752
Yes -- makes no difference what movie, or whether it's a "pure" DVD or a hybrid with both a movie and PC content.
0
 
LVL 22

Expert Comment

by:orangutang
ID: 24829277
Did you also try Autoplay Repair Wizard (http://www.microsoft.com/downloadS/details.aspx?familyid=C680A7B6-E8FA-45C4-A171-1B389CFACDAD&displaylang=en) ? Also, have you tried using another Windows account?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 70

Author Comment

by:garycase
ID: 24830475
Yes, I've tried Microsoft's AutoFix utility (one of the first things I've done), hive cleaner, disabling the antivirus program, etc.      Also tried the repair utility from Kelly's Korner;  and have examined every registry key associated with AutoPlay that I can find.    Tried the tips, utilities, and "fixes" at Tom's Hardware,  Doug Knox's site, Paul Thurrot's site, etc.    Nothing helps.

Note this is NOT an autoplay issue -- autoplay works just fine ... the choices menu pops up as it should when a DVD is inserted => it simply won't retain an "Always do the selection action" choice ... no matter which way it's set [either by checking that box when the selection menu pops up;  or by simply setting the desired action in the drive's Properties page/AutoPlay tab with "Select an action to perform"

I've also tried swapping the DVD drive (a Plextor 740) with two others (a Plex 712 and a Liteon) ... just in case this was somehow related to the drive itself.     No change.

I also restored an image of a much earlier build state -- with just XP/SP3 and all updates ... very few additional programs (just antivirus, Acrobat Reader, Flash, etc.) ==> and it STILL has the same symptoms.

Very perplexing :-)
0
 
LVL 70

Accepted Solution

by:
garycase earned 1000 total points
ID: 24831185
Fixed it :-)

I had tried disabling AVG's Resident Shield with no impact;  but completely uninstalling AVG (latest version) did the trick.    Uninstalled it; set the desired choice ... and it works fine.   Reinstalled AVG and it's still working -- so apparently the AVG process somehow interferes with setting the option.
0
 
LVL 22

Expert Comment

by:orangutang
ID: 24832836
Wow, I didn't realize you were asking this question! If I knew, I probably wouldn't have tried answering (or maybe I would...)
:)
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question