Solved

how to configure QOS in cisco 3800 & cisco 2600 router for point point videoconferencing

Posted on 2009-07-10
3
2,066 Views
Last Modified: 2012-05-07
i have MPLS vpn between my four location and also using video conferencing.
but sometime due to bandwidth problem it is creating problem for videoconferencing.
my manager has decided to implement QOS for this.

please help me to implement QOS.
AUTHORISED PERSON ONLY
 

User Access Verification
 

Username: prabhu

Password:

CISCO3845#sh run

Building configuration...
 

Current configuration : 4720 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname CISCO3845

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

no logging console

!

no aaa new-model

!

resource policy

!

no network-clock-participate wic 0

no network-clock-participate wic 1

no network-clock-participate wic 2

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

ip domain name serailway.gov.in

ip name-server 10.41.2.3

ip name-server 218.248.240.208

ip name-server 218.248.240.135

no ftp-server write-enable

!

username railnet password 7 1317161B0702013E

username prabhu privilege 15 secret 5 $1$Dztw$wWmhUMO1Ed59BOCHh/eJq.

username balaji privilege 15 password 7 120D0D12151909053E

username satheesh privilege 15 password 7 120D0D1210041F17

!

!

!

interface Multilink1

 description "Multilink 4MB to RAILTEL"

 ip address 10.255.255.234 255.255.255.252

 shutdown

 no cdp enable

 ppp multilink

 ppp multilink group 1

!

interface GigabitEthernet0/0

 description "Connected to Rail Lan Network"

 ip address 10.255.252.2 255.255.255.252

 ip access-group 10 in

 duplex auto

 speed auto

 media-type rj45

 negotiation auto

!

interface GigabitEthernet0/1

 description " This port is connected to WAN firewall "

 ip address 203.153.37.65 255.255.255.192 secondary

 ip address 10.41.2.1 255.255.0.0

 duplex auto

 speed auto

 media-type rj45

 negotiation auto

!

interface Serial0/0/0

 description " This port is connected with KGP "

 bandwidth 2575

 ip address 10.255.255.174 255.255.255.252

 encapsulation ppp

!

interface Serial0/0/1

 description "This port is connected to ADRA"

 ip address 10.255.255.190 255.255.255.252

 encapsulation ppp

!

interface Serial0/0/2

 description "This port is connected to CKP"

 bandwidth 2575

 ip address 10.255.255.238 255.255.255.252

!

interface Serial0/0/3

 description " This port is connected with RNC "

 bandwidth 2575

 ip address 10.255.255.246 255.255.255.252

 encapsulation ppp

!

interface Serial0/1/0

 ip unnumbered GigabitEthernet0/0

 encapsulation ppp

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/1/1

 description "Connected with Fairly Place"

 bandwidth 100

 ip unnumbered GigabitEthernet0/0

 encapsulation ppp

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/1/2

 description " Connecteed with 64 kbps NKG circuit "

 bandwidth 80

 ip unnumbered GigabitEthernet0/0

 encapsulation ppp

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/1/3

 bandwidth 2575

 ip unnumbered GigabitEthernet0/0

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/2/0

 no ip address

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/2/1

 bandwidth 256

 no ip address

 encapsulation ppp

 shutdown

 clock rate 2016000

 dce-terminal-timing-enable

!

interface Serial0/2/2

 description *** MPLS INTERNET ***

 bandwidth 2575

 no ip address

 encapsulation ppp

 shutdown

 no cdp enable

 ppp multilink

 ppp multilink group 1

!

interface Serial0/2/3

 description *** MPLS delhi ***

 bandwidth 2575

 no ip address

 encapsulation ppp

 shutdown

 no fair-queue

 no cdp enable

 ppp multilink

 ppp multilink group 1

!

router eigrp 11

 redistribute static

 network 10.0.0.0

 network 20.0.0.0

 auto-summary

!

router ospf 100

 log-adjacency-changes

 redistribute eigrp 11 subnets

 network 10.41.0.0 0.0.255.255 area 0

 network 10.255.252.0 0.0.0.3 area 0

 network 10.255.255.172 0.0.0.3 area 0

 network 10.255.255.188 0.0.0.3 area 0

 distribute-list 20 out

 distance 80

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.255.252.1

ip route 10.129.0.0 255.255.0.0 10.255.255.173

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 10 deny   10.41.30.254

access-list 10 permit any

access-list 10 permit 0.0.0.0 255.0.0.0

access-list 10 deny   any

access-list 20 deny   10.255.254.53

access-list 20 permit any

snmp-server community public RO

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server host 10.41.2.8 public

arp 203.153.37.66 0019.b9b2.f9ce ARPA alias

arp 203.153.37.75 0019.b9b3.c466 ARPA alias

tftp-server 10.41.5.99 alias c3845-ipbase-mz.123-14.T7

tftp-server nvram:\

tftp-server flash:c3845-ipbase-mz.123-14.T7.bin

!

control-plane

!

banner login ^C AUTHORISED PERSON ONLY ^C

!

line con 0

 password 7 045E0501062F494B1B0A0D0E130A01

 login local

 stopbits 1

line aux 0

 stopbits 1

line 1/0 1/15

line vty 0 4

 access-class 23 in

 privilege level 15

 login local

line vty 5 15

 access-class 23 in

 privilege level 15

 login local

!

scheduler allocate 20000 1000

!

end
 

CISCO3845#

Open in new window

0
Comment
Question by:diprajbasu
  • 3
3 Comments
 
LVL 16

Expert Comment

by:memo_tnt
ID: 24833559
there are a lot of factors regarding QOS and depends on your needs..
 
I recommend you to use auto QoS taht's contains the best practis for QoS by cisco
 
just add this line on the desired interface :
(config-if)#auto qos

then you can tune and change configurations depends on your needs

good ??

BR
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 24848225
plz advise status here ??

BR
0
 
LVL 16

Accepted Solution

by:
memo_tnt earned 125 total points
ID: 26060495
Hi diprajbasu

is it handled regarding your question ?

Best Regards
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now