We help IT Professionals succeed at work.

Edit Shortcut Porperties on Remote Machine

Medium Priority
639 Views
Last Modified: 2013-11-21
Hi.

Some shotcuts on remote machines are in the form "\\thiscomputername\c$\program files\myapp\myapp.exe". This was done some time ago as a quick and easy way to edit or create shortcuts on remote machines by mapping to the machine (rather than having to Remote Desktop) and, for the path, using the form \\theremotecomputername\c$\ rather than c:\ which would refer to the c: drive back here on my machine.

Following a tightening of security and permissions on the network these remote machines are now asking for a username and password to run the shortcut.  I don't want to look at permissions at this stage, I just want to change \\theremotecomputername\c$\ back to c:\ without having to Remote Desktop and without the shortcut on the remote machine thinking that the program is here on my c: drive!

Hope this makes sense!

TIA.
Comment
Watch Question

Henrik JohanssonSystems engineer
Top Expert 2008
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks henjoh.

I think we're in this position because we tried that.  On the local machine we tried creating a shortcut to, say, c:\program fles\myapp\myapp.exe mirroring what we wanted on the remote machine. We then copied this shortcut to the remote machine but the shortcut thought the app was back on the local machine and tried to run it across the network. To solve this we created a shortcut locally \\theremotemachine\c$\program files\myapp\myapp.exe and copied that over, the remote user had admin rights on their own machine so it worked OK.

If the shortcut wasn't a shortcut but a batch file we'd just edit \\theremotemachine\c$\ to c:\, what we're trying to do is the same but for a shortcut. Shortcuts seem to be too clever, i.e. when I make a mapping to the the remote machine to edit the shortcut and change \\theremotemachine\c$\ to c: it assumes that the app is on the c: drive on my machine.

This is potentially a problemn on hundreds of shortcuts so all we wanted to do when it was reported was a quick map-edit-save.  We don't want to change shares or permissions, that would be overkill. It looks like Remote Desktop-edit-save may be what we have to do.

Thanks again.
Henrik JohanssonSystems engineer
Top Expert 2008

Commented:
I just remembered having some similar issue back in old NT4 days when the shortcuts stored the machine name in the shortcuts. I haven't seen this issue since then, but try to add the following registry setting

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
LinkResolveIgnoreLinkInfo=1 (dword)

http://support.microsoft.com/kb/158682


Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.