Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 675
  • Last Modified:

iPhone & exchange 2003 Server SBS Setup

Hi,

I have an iPhone with 3.2 firmware and a windows 2003 SBS with Service Pack 2.

I opened the ports for imap4, RDP and  SMTP but when i go to setup the iphone for exchange its says verification failed and when i go to mail a message appears saying

Can not get mail - The connection to the server failed.

Any one got any ideas please

If need be i am willing to start the process of configuring the server all over again

Thanks Wayne
0
Waynepre
Asked:
Waynepre
  • 42
  • 22
  • 12
  • +2
2 Solutions
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
I would go with Active Sync, which will be your best solutions.

Test active sync with this tools https://www.testexchangeconnectivity.com/

iPhone setup:      
http://support.apple.com/kb/HT2480 
0
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Oh...make sure you have 443 open...if you have OWA setup and working with SSL you are good to go.
0
 
NpatangCommented:
If still you get the same Error Message try with Domain/Usernme in iphone setup and try unchecking t he SSL option to see if thats connect..
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
WaynepreAuthor Commented:
Hey thanks for the reply.. If i went with Active Sync would this allow me to update my e-mail on my iphone while im out and about and not connect to laptop or wifi?
0
 
NpatangCommented:
Yes it will :)
0
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Yes Active Sync works just like outlook it syncs with exchange.    So any changes you make on the iPhone will reflect next time you login to your workstation and open Outlook or OWA.

example:
So if you put a new contact in your iphone under active sync it will appears in Outlook...
0
 
WaynepreAuthor Commented:
Ok i have installed Active Sync on my server and follwed the instructions on the two links you sent me but I am still getting message

Cannot Get Mail - The connetion to the server failed. and port 443 is open

Thanks
0
 
NpatangCommented:
I think this is your first time setup.. FIrst on the server try browsing exchnage-oms and put in the crdential and let us know what do you get .
Try un checking  the SSL option in  the iphone and then try to connect.
0
 
WaynepreAuthor Commented:
yup you guess right this is my first time setting up :) ok will try this now and get back to you. thanks mate
0
 
WaynepreAuthor Commented:
OH i have already tried un checking the SSL still same thing
0
 
NpatangCommented:
Are you abel to browse Outlook web access with HTTPS// externally .....
0
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
You get the same error when testing active sync on this site:  https://www.testexchangeconnectivity.com/

My guess is you have a self-signed cert.   I would get a commercial cert or install the self-signed cert on your phone.
0
 
WaynepreAuthor Commented:
on the server if i go to IE and type in \\localhost\exchagne-oms i get

The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
--------------------------------------------------------------------------------

Please try the following:

Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
Click the Back button to try another link.
HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.  


BUT

if i type \\localhost\exchangei get the login on screen
0
 
WaynepreAuthor Commented:
ah i do have a self signed ceft, how do i go about installing it on the iphone?
0
 
WaynepreAuthor Commented:
Yes i am browsing https on external
0
 
NpatangCommented:
it is exchange-oma...

Do you have the directory in the iis with the same nam e
0
 
NpatangCommented:
You have to export the cert in the .cer format ..
connect the device to the computer with cable...
copy the cer files to the phone and then install the same on the phone
0
 
WaynepreAuthor Commented:
sorry your right when i got \\localhost\exchange-oma it asks me for username and password and i can logon with out any issues
0
 
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Go to the OWA site and click on the Certificate Error or the Lock...select view certifcates, cert opens...click Details button then Copy to File...
0
 
NpatangCommented:
try the same from outside the domain .. try brwsing exchange-oma externally.. somesetings are wrong on the iphone itself it seems ..
0
 
WaynepreAuthor Commented:
ok when i went to oma externally i was getting error you do not have permissions to view this page...

I then Gave access to all computers and now i am able to view oma externally.

in the server on the iphone do i type domain/exchange-oma ?

to access my web outlook i just type domain/exchange

0
 
NpatangCommented:
for ows just type /exchange.
in Iphone you don't have to type /exchange-oma.
Just the url of OWA withut exchange or exchange-oma
0
 
WaynepreAuthor Commented:
Ok if i type in server field on the iphone:

domain.co.uk/exchange and try to view mail i get  Cannot Get Mail - The connetion to the server failed.

if i type

domain.co.uk and try to view mail i get Cannot Get Mail - The connetion to the server failed.

but if i type

domain.co.uk/exhcange-oma and try to view mail i get no message and just a blank screen i can see inbox but nothing else
0
 
WaynepreAuthor Commented:
my OWA is domain/exchange i type that in and i get connection error
0
 
NpatangCommented:
is domain.co.uk is your external url which you use for Outlook web access.......   if yes this is the correct one which you have ot put//

no need to add /exchange or /exchange-oma in iphone
0
 
WaynepreAuthor Commented:
ok just to make sure

if i type in my web browser.....

http://www.domain.co.uk     - LOADS WEBSITE
https://www.domain.co.uk/exchange    - loads OWA

on i phone if i only type:

domain.co.uk

i get the connection error

this is what i don't know how to get around.

I have logged on to the OWA and copied the cert. now another silly question sorry guys, how do i copy the file to the iPhone as there is no way to do this from what i can see in iTunes.

I am new to the iPhone and iTunes

Thanks for your help and time with this.
0
 
NpatangCommented:
This is what you need to type in your iphone

www.domain.co.uk 
0
 
WaynepreAuthor Commented:
ok done that..

When i type that in and go to Mail
It loads directly in to the inbox and does nothing.

If i click on refresh icon it comes up and says

Cannot get mail - the connection to the server failed
0
 
NpatangCommented:
try installing thecertificate on the device
Check these links
http://support.apple.com/kb/HT1385 
http://www.experts-exchange.com/Apple/Hardware/iPhone/Q_23403813.html 
0
 
WaynepreAuthor Commented:
thansk for this

how do i install he cert on the device? i don';t know how to copy it accorss from iTunes also i looked at http://www.experts-exchange.com/Apple/Hardware/iPhone/Q_23403813.html

and it is showing an advance option which i can not find on my iPhone any ideas?
0
 
NpatangCommented:
Copying the content from that link

If you are using SSL, what kind of certificate are you using on your Exchange front end?  If you did not purchase a Commercial SSL certificate then you are going to have problems using SSL on the iPhone - the only way to get a Self-Signed SSL certificate's root CA cert onto the iPhone trusted root CA certificate store is by syncing it with a Mac that has imported the certificate into the user's keychain.  
0
 
UncleMarvCommented:
Some things seem to be missing from what the others suggested.
Which generation iPhone is this? The first generation did not work well. If this is a 3g or 3gs, then you should be able to connect by using http://mail.domain.com or whatever your MX record says.
The exchange-oma mentioned is a configuration within IIS on your server. That shouldn't need to be changed unless is is not accepting connections from outside IP addresses. YOu can check that under the directory security tab along with authentication and access control. You can check basic authentication versus integrated windows authentication to see which works.
Most mail admins do not check SSL, so see if unchecking that helps as well.
0
 
WaynepreAuthor Commented:
ah so i gonna have to use a commerical SSL.

I am on a pc and im guessing i cannot copy it directly from here.

if i turn off SSL will the iPhone work then?
0
 
NpatangCommented:
yes it should
0
 
NpatangCommented:
For your information here another link

http://forums.a2hosting.com/showthread.php?tid=388
0
 
WaynepreAuthor Commented:
Ok i have now removed SSL so to access my e-mail now i have to type in IE http://www.domain.co.uk/exchange NOT https

I have changed the SSL setting on i phone and it still isn;t working...

sorry mate

ummm.
0
 
NpatangCommented:
Waynepre try installing the crt on iphone , lets not change the settings of SSL for OWA...as you already have exchange-oma withput ssl and exchange Activesync will comuunicate on that directory by default in SBS
0
 
WaynepreAuthor Commented:
ok,

I have put the crt back, and told exchagne on my iphone to connect to exchagne-oma with ssl disabled but it still says cannot get mail :(
0
 
NpatangCommented:
Don't enable SSL on exchange-oma  just enable the SSL on iphone
0
 
NpatangCommented:
Can you get me the IIS logs from the server and what the error you are getting in the app log
0
 
WaynepreAuthor Commented:
I think i know what might be the problem...

I may be a dip stick here..... But how do i configure the server for Active Sync do i need to download and install something??? for example

http://www.microsoft.com/windowsmobile/en-us/help/synchronize/activesync-download.mspx
0
 
NpatangCommented:
No you don't have to install any software for Exchange Activesync. The software which you ar ementioning in the link is actuualy for Desktop Activesync when you use the USB cable.

On the server  you just need to make sure that .

1) Go into the properties of exchange-oma > directory security> Edit

Check the integrated Authentication and basic Authentication should be checked. Also SSL should be unchecked and no ip address should ne in restrictions.

2) Go into the propertied of the Exchange activesync directory and > Directory Security and > Edit and make sure that only basix AUth shold be check and Disabling and Enabling the SSL is your wish
0
 
WaynepreAuthor Commented:
thanks for this mate,

I have completed option 1 but with regards to option two i can not find the excahange active sync directory.. How do i install this?
0
 
NpatangCommented:
The directory name should be Microsoft-server-ActiveSYnc.. You don't have to install it .. that shold be by defualt there.
0
 
WaynepreAuthor Commented:
ah silly me i found it and done what you advised

simple answer it didn't work

still getting error cannot get mail
0
 
WaynepreAuthor Commented:
Ok a new one,

I have just enabled SSL again on iPhone..
Click on mail and Inbox shows but won;t update no error message not even after i press refresh. Just says updated date time

no other folders or e-mails
0
 
NpatangCommented:
DO you have windows mobile device just check where the issue is ?
0
 
WaynepreAuthor Commented:
no i don;t anymore i gave it away about two weeks ago :( doh
0
 
NpatangCommented:
Send the IIS lgs from the server

Start > Run > Logfiles> W3sc100> Latest dates log files
0
 
WaynepreAuthor Commented:
Please see log file attached :)
ex090711.log
0
 
NpatangCommented:
make sure that the domain name you enter in the device should match with the one which is mentioned in the Active directory user properties.
Make sure you have all the lates updates on the server
0
 
WaynepreAuthor Commented:
i am typing in the correct domain name
0
 
WaynepreAuthor Commented:
Server is also upto date
0
 
Alan HardistyCommented:
Have you run the check on the first comment on this question?  Pease report back with the results here so Experts can help you more easily.
https://testexchangeconnectivity.com
Select the Exchange Activesync test, fill in your details and if you use a Self-Cert - tick the Ignore Trust for SSL box.
0
 
WaynepreAuthor Commented:
Sorry i thought i already had said it come back saying it had completed successfully, i have just ran another check and agian it said Connectivity Test Successful
0
 
Alan HardistyCommented:
If all is well with the test, then there is no reason for the iPhone not to sync properly.
When setting up the iPhone - have you accepted the certificate when it prompts?
0
 
WaynepreAuthor Commented:
its not prompting for a certificate it was before but now its not
0
 
WaynepreAuthor Commented:
oh i tell a lie it just did.. I accepted and it says  Exchange account verification failed
0
 
Alan HardistyCommented:
Credentials could be wrong, Check the username and password - reset the password on the server if necessary.  Ensure you enter the domain name in (e.g., yourcompany).
0
 
WaynepreAuthor Commented:
nope they are correct i can log on to the VPN, OWA with these details.
I have tried both my account and the administrator account. reset passwords and still getting same error.

I have even tried reloading iPhone firmware
0
 
WaynepreAuthor Commented:
When i go into Mail it says Cannot Get Mail - The connection to the server failed
0
 
Alan HardistyCommented:
What are you using for the server name?
0
 
WaynepreAuthor Commented:
www.domain.co.uk as advised i have also tried
http://www.domain.co.uk
domain.co.uk/exchange
domain.co.uk/exchange-oma
https://www.domain.co.uk
https://www.domain.co.uk/exchange-oma
https://www.domain.co.uk/exchange

so on
0
 
Alan HardistyCommented:
Server should be www.yourdomain.co.uk - this should match the name on the certificate.  Does it?
0
 
WaynepreAuthor Commented:
it does.

This Cert was created by SBS 2003 during setup, its not a commercial cert but they both do match up.
0
 
Alan HardistyCommented:
Can you run through this document and rebuild / check your Exchange config please.
http://support.microsoft.com/kb/883380 
0
 
WaynepreAuthor Commented:
sure do it now and get back to you
0
 
WaynepreAuthor Commented:
ok just completed the document i am able to access web mail again but still not working on iphone
0
 
Alan HardistyCommented:
Can you email me a set of test credentials please (see my profile) - will need all the info - I will test on my iPhone and Windows Mobile phone.
0
 
WaynepreAuthor Commented:
of couse i can do you have MSN so i can send them to you in private?
0
 
Alan HardistyCommented:
My email address is in my profile - click on my name to get to my profile.
0
 
WaynepreAuthor Commented:
info - kewl done!

Thanks for this....
0
 
Alan HardistyCommented:
Seems to be working on my iPhone 3Gs happily in terms of Account Setup.  Just sent a test email to the address you emailed me from and it comes back Cannot Send Mail - have you got any of the Virtual Directories set to restrict by IP?
 
0
 
WaynepreAuthor Commented:
no they are all unrestricted...

i still cannot connect on my iphone 3g
0
 
WaynepreAuthor Commented:
Did u connect via imap or Exchagne on iphone?
0
 
Alan HardistyCommented:
Are you sure you are on Exchange SP2?
0
 
WaynepreAuthor Commented:
nope i was wrong i am using SP1 now downloading SP2 Opps. I am now banging my head against a brick wall and hold my head down in shame
0
 
WaynepreAuthor Commented:
oh and i feel like a right plonker
0
 
Alan HardistyCommented:
Fingers corssed it is that simple!
0
 
WaynepreAuthor Commented:
fingers toes, arms legs :)
0
 
WaynepreAuthor Commented:
no comment... thank you all for your help
0
 
Alan HardistyCommented:
Are we cooking with gas?
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 42
  • 22
  • 12
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now