Solved

ISINTEG Utilty not working??

Posted on 2009-07-11
30
1,354 Views
Last Modified: 2012-05-07
after the ESEUTIL /p repair, when i try the ISINTEG -s servername it displays the belwo.. is there a syntax error or what, i can't figure this out. (by the way, info store does mount successfully i just need to do isinteg now)

D:\Program Files\Exchsrvr\bin>isinteg -s email-server -test alltest

Microsoft Exchange Information Store Integrity Checker v6.5.7638.2
Copyright (c) 1986-2000 Microsoft Corp.    All rights reserved.
Usage:
 isinteg -s ServerName [-fix] [-verbose] [-l logfilename] -test testname[[, test
name]...]
    -s               ServerName
    -fix             check and fix (default - check only)
    -verbose         report verbosely
    -l filename      log file name (default - .\isinteg.pri/pub)
    -t refdblocation (default - the location of the store)
    -test testname,...
       folder message aclitem mailbox(pri only) delfld acllist
       rcvfld(pri only) timedev rowcounts attach morefld ooflist(pri only)
       global searchq dlvrto replstate(pub only)
       peruser artidx(pub only) search newsfeed(pub only) dumpsterprops
       Ref count tests: msgref msgsoftref attachref acllistref aclitemref
       newsfeedref(pub only) fldrcv(pri only) fldsub dumpsterref
       Groups tests: allfoldertests allacltests
 isinteg -dump [-l logfilename] (verbose dump of store data)

D:\Program Files\Exchsrvr\bin>

Thanks
0
Comment
Question by:badabing1
  • 11
  • 9
  • 6
  • +3
30 Comments
 
LVL 15

Expert Comment

by:tntmax
ID: 24831959
"alltest" or "alltests"  (do you have the extra 's' at the end?)
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24831997
For further understanding of INinteg command have a look on
http://support.microsoft.com/kb/q182081/
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24832025
Run - ISINTEG fix -test alltests - then select the mailbox store which you need to run the test. also the mailbox store must be in dismounted state to run the test.
Check the msexchange article for more details.
http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html 
0
 

Author Comment

by:badabing1
ID: 24832207
tHANKS BUT nothing is working!

i type

isinteg -s servername -fix (doesnt work)
isinteg -s servername -test alltest and with  (s) (dosent work)
isinteg -fix -test alltests (as suggested by subsun dont work) link dont work.

Npatanq- i have seen this article before?  How difficulct can this be gents? I have exchange 2003. this is what i type

Isinteg -s servername -fix (this is the synatx in help of isinteg).

so why am i getting the above in first post??

Please help..
0
 

Author Comment

by:badabing1
ID: 24832211
Subsun -
to add to the previuos post, i dont get the option to choose the mailbox store. it seems like isinteg isnt executing. my first post is the exact screen print when i ran isinteg!
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24832227
hey as you written in your first port that your ran "after the ESEUTIL /p repair, when i try the ISINTEG ".

Have you ran Offline defrag its a prerequisite to tun isinteg
0
 

Author Comment

by:badabing1
ID: 24832299
yes  i have, i belive its the synatx that i am not use correctly,

any suugestion?
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24832305
SImple commanf for isinteg

after going to bin Virtual directory isinteg -s Server netbios name -fix -test alltests
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 24832318
From D:\program files\exchsrvr\bin direcory in a DOS Prompt type the following:
isinteg -s servername -fix -test alltests
(change servername for your exchange server's name)
That command should work and then prompt you to choose a mailstore to check.
The mailstore has to be offline before you can run isinteg.
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24832321
hey make sure that Information strore servive should be started and store should be dismonuted
0
 

Author Comment

by:badabing1
ID: 24832354
People,

i have typed all the above and nothing works, however, the command alltests is not in the available commands in help of isinteg.

there is however, a command allfoldertests, which i have used and it seems to be working.

I cant believe, no one is aware of this and why "alltests" is not avialabe perhaps its been replaced with allfoldertest?

Thanks
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832358
What version of Exchange are you using?
0
 

Author Comment

by:badabing1
ID: 24832361
so why is alltests not working then?
0
 

Author Comment

by:badabing1
ID: 24832368
exchange 2003 sp2
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832370
Here is a screenshot of my server Server 2003 Exchange 2003 SP2 which works happily with those commands.  If your server does not like these commands, then there is an issue / configuration problem stopping them running.
 

isinteg.jpg
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 
LVL 8

Expert Comment

by:Npatang
ID: 24832372
Have you try running the command

isinteg -s Server1 -test allfoldertests  which is mentioned in the artcle whcih was shared with you before ?  may be you have just to make sure
0
 

Author Comment

by:badabing1
ID: 24832384
Npatanq- this command works, but why not alltests? so if i when i use -fix what do ineed to specify?

i was thinking - isinteg -s severname -fix

will this work?
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24832390
Not sure exactly as Alan there can issue / configuration problem stopping them running..
0
 

Author Comment

by:badabing1
ID: 24832398
allanharddisty-

would you mind running isinteg /? and see if it is same with below?

D:\Program Files\Exchsrvr\bin>isinteg /?
Microsoft Exchange Information Store Integrity Checker v6.5.7638.2
Copyright (c) 1986-2000 Microsoft Corp.    All rights reserved.
Usage:
 isinteg -s ServerName [-fix] [-verbose] [-l logfilename] -test testname[[, test
name]...]
    -s               ServerName
    -fix             check and fix (default - check only)
    -verbose         report verbosely
    -l filename      log file name (default - .\isinteg.pri/pub)
    -t refdblocation (default - the location of the store)
    -test testname,...
       folder message aclitem mailbox(pri only) delfld acllist
       rcvfld(pri only) timedev rowcounts attach morefld ooflist(pri only)
       global searchq dlvrto replstate(pub only)
       peruser artidx(pub only) search newsfeed(pub only) dumpsterprops
       Ref count tests: msgref msgsoftref attachref acllistref aclitemref
       newsfeedref(pub only) fldrcv(pri only) fldsub dumpsterref
       Groups tests: allfoldertests allacltests
 isinteg -dump [-l logfilename] (verbose dump of store data)
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832404
Yep - the same.
isinteg.jpg
0
 

Author Comment

by:badabing1
ID: 24832419
believe or not, its worked this time but now comes with the message below- what is this?

Isinteg cannot initiate verification process.
  Please review the log file for more information.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832431
What errors do you get in the Application Event Log?
Start, Run, eventvwr.exe
 
0
 

Author Comment

by:badabing1
ID: 24832450
well its now running, i had take public folders offline as well..

Things are really wierd, they work one minute and the next they dont..

last question, if all test are successfull is it still worth while doing a -fix command?

i ask this because my backup has been failing due to this error-

Event Type:      Error
Event Source:      ESE
Event Category:      Logging/Recovery
Event ID:      478
Date:            09/07/2009
Time:            12:48:50
User:            N/A
Computer:      server
Description:
Information Store (4528) The streaming page read from the file "D:\Program Files\Exchsrvr\mdbdata\priv1.stm" at offset 3093106688 (0x00000000b85d1000) for 4096 (0x00001000) bytes failed verification due to a page checksum mismatch.  The expected checksum was 3970952080 (0x00000000ecafeb90) and the actual checksum was 3903843216 (0x00000000e8afeb90).  The read operation will fail with error -613 (0xfffffd9b).  If this condition persists then please restore the database from a previous backup.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832458
It sounds like you need to run eseutil /r to recover the database first.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832463
0
 

Author Comment

by:badabing1
ID: 24832469
how does this command exactly works eseutil /r

my info store mounts successfully, so why do i need to run the above command?

cheers
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832538
The command is:
eseutil /r e00 /l "location of log files"
type eseutil /r for more info in DOS prompt.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24832556
You need to run the command because the database is in a Dirty Shutdown state - Replaying the log files will bring it to a clean shutdown state.
Run eseutil /mh "path to exchange database" to check.
0
 

Expert Comment

by:UncleMarv
ID: 24832635
If nothing is happening... are you running the command line from the correct path? If you don't add the Exchange folder to be a parth of your path, you will need to make sure you are in the C:\program files\exchsrvr\bin\ folder. The screen shot from alanhardisty  shows it.
The other consideration is after reading all of the documentation, are you sure that you took the information store offline?
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24833053
Hey Dude, Sorry for not responding, I was not getting the notifications from EE. Somehow some additional characters added to my post that's why the link was not working... Check this, you can keep it for future reference.
http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
0

Featured Post

Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

Join & Write a Comment

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now