Solved

WRT160NL Linksys router, Ubuntu 9.04 7/11/09

Posted on 2009-07-11
2
1,713 Views
Last Modified: 2012-05-07
Salutations.

     I am running Ubuntu/Kubuntu 9.04 64-bit, Jaunty Jackalope, currently updated completely at 9:44. My motherboard is MSI 790GX-G65, with an AMD Phenom II CPU and two routers. One currently works as a wired router, but is being replaced due to it's wireless dying. It is a Netgear WGT624v3. The router I am currently migrating to is a WRT160NL. I have gone to it's configuration page and set up everything to the settings provided by my ISP, Comcast. It is set to use DHCP and automatically acquire the IP address. However, it doesn't appear to obtain any IP address, as the IP address on the "Status" tab is content with 0.0.0.0. As you may have guessed, this means I cannot connect to the internet through this router.

     Something rather peculiar about this is that we cannot plug the computer directly into the modem and get an internet connection, but we can plug it into the Netgear WGT624v3 and we will have a connection. At any rate, I did some research into the problem, and it seems that Jaunty Jackalope's Dhclient.conf, the file which tells Ubuntu how to dynamically obtain IPs, has a small typo in it that prevents it from connecting correctly. I tried as those guides had said, but everytime I attempted to run with the new file, it wouldn't let me obtain a connection, even on my old router.

     My Dhclient, unmodified, is posted in the code box. I need this file fixed, if it is the problem, or if it is not the problem, then I need to know how to get my new router to obtain the dynamic IP. Gentlemen....start your engines.
# Configuration file for /sbin/dhclient, which is included in Debian's

#	dhcp3-client package.

#

# This is a sample configuration file for dhclient. See dhclient.conf's

#	man page for more information about the syntax of this file

#	and a more comprehensive list of the parameters understood by

#	dhclient.

#

# Normally, if the DHCP server provides reasonable information and does

#	not leave anything out (like the domain name, for example), then

#	few changes must be made to this file, if any.

#
 

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;
 

send host-name "<hostname>";

#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;

#send dhcp-lease-time 3600;

#supersede domain-name "fugue.com home.vix.com";

#prepend domain-name-servers 127.0.0.1;

request subnet-mask, broadcast-address, time-offset, routers,

	domain-name, domain-name-servers, domain-search, host-name,

	netbios-name-servers, netbios-scope, interface-mtu,

	rfc3442-classless-static-routes, ntp-servers;

#require subnet-mask, domain-name-servers;

#timeout 60;

#retry 60;

#reboot 10;

#select-timeout 5;

#initial-interval 2;

#script "/etc/dhcp3/dhclient-script";

#media "-link0 -link1 -link2", "link0 link1";

#reject 192.33.137.209;
 

#alias {

#  interface "eth0";

#  fixed-address 192.5.5.213;

#  option subnet-mask 255.255.255.255;

#}
 

#lease {

#  interface "eth0";

#  fixed-address 192.33.137.200;

#  medium "link0 link1";

#  option host-name "andare.swiftmedia.com";

#  option subnet-mask 255.255.255.0;

#  option broadcast-address 192.33.137.255;

#  option routers 192.33.137.250;

#  option domain-name-servers 127.0.0.1;

#  renew 2 2000/1/12 00:00:01;

#  rebind 2 2000/1/12 00:00:01;

#  expire 2 2000/1/12 00:00:01;

#}

Open in new window

0
Comment
Question by:DaveRoehrman
2 Comments
 
LVL 87

Accepted Solution

by:
rindi earned 500 total points
Comment Utility
I'm not sure I completely understand your system. If you have a separate modem, why do you have to use any of your ISP's settings on the wireless router? Wouldn't those have to be set in the modem, and not the router? Or have you setup the modem to be in bridging mode? If the modem isn't set to bridging mode, and the router is connected via it's wan port to the modem, you should only have to setup the router to acquire it's IP from the modem via DHCP. You shouldn't have to setup any login information etc on the router. Also when connecting the router to the modem, power-cycle the modem, this should force it to acquire a new IP from the ISP and also make it forget the old router.
0
 

Author Closing Comment

by:DaveRoehrman
Comment Utility
Your power-cycle (reset) suggestion was all it took!  Thanks very much for your attention!
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now