How can I access resources on a Window Server 2008 Domain from a Windows 3.11 workstation?

I need to access resources from a Server 2008 Domain from a Windows For Workgroups 3.11 Workstation. This workstation has connected to a Server 2003 domain previously. We needed to make a few modifications to the Domain Controller group policy to get it to connect. These were security settings to do with encryption requirements etc. We have made the same changes to our newly built SBS 2008 box and we cannot get the WFW 3.11 system to connect.

At the moment the workstation can ping the 2008 server, it can resolve the server name and it can browse to connect to a share off the 2008 server but it still asks for a password on connection which fails. They password prompt only asks for a password so you can't change the username and I'm not sure what it's trying to connect as. The WFW 3.11 workstation logs on using a username and password which exists on the 2008 domain.

Any help would be much appreciated.
LVL 3
activitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
Is there no other way around this, i.e you do not have the option of upgrading the client?
Connecting a Win98 client to a 2003 server is a task in itself and reduces security considerable. Allowing 3.11 to access a 2008 server which uses NTLM2 is going to drastically reduce the security advantages of 2008 and be even more difficult to do.

I have never connected even a Win2K to 2008,  so but the first requirement for 3.11 would be to disable SMB signing:
Group Policy Management Console, under the "Default Domain Controller's Policy", go to:
Computer Configuration| Windows Settings| Security Settings | Local Policies | Security Options folder | disable - Microsoft network server: digitally sign communications (always) policy setting

Having said that it may adversely affect XP sp3 and Vista clients.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob WilliamsCommented:
I stumbled on the following discussion which may be of some help:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_24041160.html
0
activitAuthor Commented:
The client is actually inbuilt for an industrial Metal pressing machine and so it can't be upgraded or changed in any way. I'll double check that SMB disabling via the digital signed(always) policy while I'm in there this morning but I have a feeling I have already disabled that.
0
DNadon57Commented:
Has your problem been resolved?  I ran into a similar situation with Linux / Samba and trying to access Win 2008 resources.  The problem had something to do with SMB 2.0.  You may want to try disabling SMB 2.0 in the server to see if it resolves the issue.  Here's a link that describes this.  http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.