Why is my datasource path being 'lost' when using Word 2007 Mailmerge and datasource on a Network drive.?

Since my PC has been upgraded to Word 2007, I have some problems with CSV mailmerge data sources stored on a network drive, which worked fine with word 2003.
My existing mailmerge documents now report 'Data source can not be found' after the SQL statement and I have to locate the data source and even though I save the mailmerge document, I still have to manually link the data source every time time. New Word 2007 mailmerge documents that have data sources from the network drive appear not to save any link at all. When I re-open  the mailmerge document, there is no SQL statement and it is just like a normal word document - so again the data source has to be found and opened manually via the mailmerge options.
After some experimenting, I found that the mailmerge data source links will save perectly on my C: drive - however I would like to solve the problem of why this doesn't work on the network !
CallaoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joanne M. OrzechManager, Document Services CenterCommented:
Although I realize the KB I'm linking to refers to an earlier version, I am posting anyway - I think it's still applicable... I would try adding your network locations to trusted locations in IE.

http://support.microsoft.com/default.aspx/kb/834699

 
Method 1: Trust the location in Internet ExplorerTo trust the location where your data source is located on your intranet, follow these steps: Start Internet Explorer.  
   
On the Tools menu, click Internet Options.  
   
On the Security tab, click Local intranet, and then click Sites.  
   
In the Local intranet dialog box, click to select each of the three following check boxes as appropriate, and then click OK: Include all local (intranet) sites not listed in other zones.  
   
Include all sites that bypass the proxy server.  
   
Include all network paths (UNCs).  
   
Note If your data source is in a location that is not covered by any one of these three check boxes, click Advanced, and then add the Web site that contains your data source.  
   
Click OK to close the Local intranet dialog box.  
   
Click OK to close the Internet Options dialog box.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CallaoAuthor Commented:
Many thanks - I will try this and see if this works!
0
Joanne M. OrzechManager, Document Services CenterCommented:
Oh - well Callao - you shouldn't have accepted my answer until you've tested it and are sure that it works... let me know if it doesn't work, and I can unaccept your answer for you and perhaps other experts have thoughts.

Joanne Orzech
MS Word MVP
EE Zone Advisor
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.