Exchange 2007 will not receive emails from outside world

For the past 3 days I have been trying to get Exchange 2007 to receive email from outside sources with no luck.  Most people will not post their domain names and ip addresses but I need to get this done and its driving me crazy.

internal domain name is Compmia.local
internal domain controller name is srvw2k8.compmia.local
exchange server name is srvw2k8exch.compmia.local

I have a sonicwall 2040 pro
added nat and opened ports for mail.

my website address is compmia.com
subdomain for mail is mail.compmia.com
modem static ip address is 72.156.20.251

Compmia.com (mx record) points to mail.compmia.com
Mail.compmia.com (a record) points to 72.156.20.251 which is my modem static ip address.
Mail.compmia.com (mx record) points to mx01.1and1.com which is my domain host.

I don't know which to make the trusted domain, compmia.local or compmia.com
my user are created with their email at .local, i know how to change it in the policy to .com but which do I use.

I created the connectors to us anonymous

does my isp have to do anything else for this to work or do I only need the changes i made from my domain host.

dns settings on my domain controller, I can really use some help on that.

I dont know why I cant receive email, Ive tried many things for the last 3 days, any help is appreciated, thanks.
bbrunetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Telnetting to the IP you list on port 25 does not come back with your mail server!
Is you server configured to use port 25?
Are all your services started?
0
MesthaCommented:
Is this SBS or the full product?
If it is the full product, then go through this Exchange team article:
http://msexchangeteam.com/archive/2006/11/17/431555.aspx

If it is SBS, then ensure that you have completed the wizards.

The most common problem is not enabling anonymous on the Receive Connector.

If I telnet to mail.compmia.com on port 25, the ehlo doesn't look correct.

It should look like this:

220 server.example.co.uk Microsoft ESMTP MAIL Service ready at Sun, 12 Jul 2009 23
:10:41 +0100
ehlo
250-host.example.co.uk Hello [192.168.3.101]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250 XRDST

it actually looks like this:

220 mail.compmia.com Microsoft ESMTP MAIL Service ready at Sun, 12 Jul 2009 18:0
5:29 -0400
ehlo
250-mail.compmia.com Hello [123.123.123.123]
250-SIZE 10485760
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-AUTH LOGIN
250-8BITMIME
250-BINARYMIME
250 CHUNKING

That could be a sign of interference somewhere - the firewall maybe.
Simon.
0
Alan HardistyCo-OwnerCommented:
Simon, I know you are good, but you must have special powers - I get absolutely zip when telnetting on port 25!
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

bbrunetAuthor Commented:
This is the full product, exchange 2007 enterprise with server 2008 enterprise.

guys this is what I have

 in receive connector

general tab
fqdn this connector will provide, mail.compmia.com

network tab, local ip addresses, all available ipv4 addresses port 25
receive mail from remote servers that have these ip addresses: 0.0.0.0-255.255.255.255

authentication tab, I have checked off, transport layer security, enable domain security, basic authentication.

permission groups tab, i have all checked except partners.

hub transport, Accepted domains tab, i have two domains compmia.com(true) and compmia.local(false)

In send connector this is what I have.
general tab, fqdn this connector will provide in response to helo or ehlo, mail.compmia.com

address space tab, smtp * cost 1

Network tab,  checked off use dns "mx" records to route mail automatically.

source server tab, my mail server name which is srvw2k8exch
0
Chris DentPowerShell DeveloperCommented:

Can we send to "Administrator@"? Assuming not since I get unable to relay for that particular address.

Chris
0
Alan HardistyCo-OwnerCommented:
This are the replies that I get:
administrator@compmia.com on 13/07/2009 10:02
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <mail.mymailserver.co.uk #5.7.1 smtp;550 5.7.1 Unable to relay>
postmaster@compmia.com on 13/07/2009 10:04
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <mail.mymailserver.co.uk #5.7.1 smtp;550 5.7.1 Unable to relay>
0
Chris DentPowerShell DeveloperCommented:

Which may indicate a problem with the "Accepted Domains", but we should try it with a valid recipient first (if neither of those are) :)

Chris
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alan HardistyCo-OwnerCommented:
It's no use having your local users with .local email addresses as when they send out - they will send out as .local which will never find it's way back to you.
Set the default email address to .com and trust this domain.
0
bbrunetAuthor Commented:
chris-dent had the correct idea, I hade my accepted domain, when first setup with a typo error.  Unless of having compmia.com on both places I had put compia.com and I did not see the typo error.  Thanks for all of your help guys.  Yes its embarrassing.
0
bbrunetAuthor Commented:
alanhardisty also had it correct and pointed me in the correct direction with email addresses had to be with .com and not .local. thanks.
0
bbrunetAuthor Commented:
I want to give chris and alan 250 each I dont know how to do it, can someone correct this, thanks.
0
bbrunetAuthor Commented:
Thanks a lot guys.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.