Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1042
  • Last Modified:

Quartz Extreme, Radeon HD, and Final Cut

I've been using Final Cut for months with no issue.  This morning I tried to launch Compressor and it told my my hardware doesn't meet Final Cut's requirements.  Specifically it said I need a graphics card that supports Quartz Extreme.  I have an ATI Radeon HD 2600 XT that came with the Mac Pro.  What's causing this?  Does the card in fact not support Quartz Extreme and a software update for Final Cut made it change its mind about my system?  Is the system wrong about my graphics card?  Do I really need to upgrade my hardware?

Mike
0
shacho
Asked:
shacho
  • 2
  • 2
1 Solution
 
Britt ThompsonSr. Systems EngineerCommented:
Here's a firmware update for the video card...if you go to system profiler and view the card information does it say "Quartz Extreme: Supported" under the specs? This could be related to the recent updates and the firmware update may resolve the issue.

http://www.apple.com/downloads/macosx/apple/firmware_hardware/atiradeonhd2600xtfirmwareupdate.html
0
 
shachoAuthor Commented:
System says that my driver is up to date when I try to run the installer.
0
 
Britt ThompsonSr. Systems EngineerCommented:
Those cards definitely support Quartz Extreme...are you somehow running this machine where the monitor isn't attached when you start up? Or, is it a render node? Quartz Extreme will not be loaded unless a monitor is attached to the video card when it starts. Are you using a KVM?

Also, try swapping the DVI port the monitor is attached to.
0
 
pheidiusCommented:
double check and see if it is enabled in the os. The card may be supported but it may be switched of in the os. Below are command line ways to re-enable but you can also use the quartz debugger utility found in the developer tools section in the optional instal section on your original instal dvd

Method 1
Open com.apple.windowserver.plist
This file is located in /Library/Preferences
Change the Quartz2DExtremeEnabled value to YES.
Method 2


If you would like to enable Quartz 2D Extreme (see this hint for more info on it), but don't have the VRAM to support it, you can change the minimum requirements by following these steps in the Terminal:

$ cd /System/Library/Frameworks/ApplicationServices.framework/Versions\
/A/Frameworks/CoreGraphics.framework/Versions/A/Resources
$ sudo pico Configuration.plist

Once in the editor, change these values to match your machine (use System Profiler to get the required details):

<dict>
<key>Quartz2DExtremeEnabled</key>
<true/>
<key>Quartz2DExtremeMinimumVRAM</key>
<integer>64</integer>
<key>Quartz2DExtremeMinimumDRAM</key>
<integer>512</integer>
<key>Quartz2DExtremeVendorDisabled</key>
<array>
</array>
</dict>



Both of these methods keep Quartz 2D Extreme enabled across reboots.
0
 
shachoAuthor Commented:
Thanks!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now