Exchange 2007 Outlook Web Access Light timeout

I need to adjust the timeout on my outlook web access for the light mode.  It is timing out at 5-10 minutes.
I have created 2 registry key's in HKLM\System\CurrentControlSet\Services\MSEchange OWA

They are PublicClientTimeout (set at 60), and TrustedClientTimeout (Set at 240).  I have restarted IIS and W3SVC, and there's been no change.

Is there a regedit I am missing?

Is there anything else
ksuchewieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

debuggerauCommented:
not sure about regedit yet, I goto IIS management and change the timeout on the web server firstly..

untitled.JPG
0
ksuchewieAuthor Commented:
That does not seem to make a difference for the Light version.  I still get the message, "Message automatically saved
Click here to recover the last item you were working on  
 The item you were working on was automatically saved to the Drafts folder because no action occurred for an extended period of time. You may be required to log on again. "

I set it for 60 minutes.  I did reset IIS.  It timed out after 5 minutes.
 

sessionstate.JPG
0
debuggerauCommented:
Found these links:
http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1231470_mem1,00.html

And this description, hope it helps..

A. By default, when OWA has forms-based authentication enabled, sessions have a 15-minute inactivity timeout for public or shared computers and 24 hours for a private computer. If you're using a public computer to compose a long email message that takes more than 15 minutes to write, the session will time out and you won't be able to send the message. You can change this timeout value (which is the cookie lifetime) by using this procedure:
1. Log on to the Exchange server as an Administrator.
2. Start the registry editor (regedit.exe).
3. Navigate to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA subkey.
4. From the Edit menu, select New - DWORD value.
5. Enter a name of PublicClientTimeout and press Enter.
6. Double-click the new value and set it to the desired number of minutes before a timeout (1 to 4320), set the type to decimal, and click OK.
7. To set the timeout period for a private client, repeat the process of creating a DWORD value, but this time enter a name of TrustedClientTimeout and again set the value to the number of minutes before a timeout (The value for private computers should be significantly higher than for public computers.)
8. Stop and restart the World Wide Web (WWW) Publishing service by using these commands at the command line.

net stop w3svc net start w3svc
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

ksuchewieAuthor Commented:
That is what I've already tried...and it doesn't make a difference for the LIGHT version.

The light version times out after 5 minutes.
0
debuggerauCommented:
I see you reset IIS, but did you reset the exchange services though?


0
ksuchewieAuthor Commented:
I reset IIS and W3SVC.  That's all I've found to reset.  What else needs to be reset?
0
debuggerauCommented:
I'd be giving exchange a cycle too..

Are you using form based authentication?

Was this the guide your using?
http://anewmessagehasarrived.blogspot.com/2009/01/owa-authentication-and-its-affect-on.html
0
serafiraCommented:
Ksuchewie,
 We are having the same problem... did you ever get a resolution?
Serafira
0
ksuchewieAuthor Commented:
no resolution yet on my side
0
debuggerauCommented:
0
ksuchewieAuthor Commented:
debuggerau:
I have already tried that setup.  That does not seem to affect the light version timeout.  
0
debuggerauCommented:
ok, let do some test, I've just checked that the timeout is above 10mins, but less than 19Mins.
Will narrow the time down a little more before registry change to shorten the period.
It is a cookie timeout, so it will be that time period after last use; each time you change the page, it will reset the timer (from the server, not locally).

10:52 last change
11:07 still working
11:27 returns to login
11:28 modify reg key for 5 Minutes.
11:31 reset IIS
11:34 start test again
11:44 try and test, logged off as expected.

So the registry setting do have an effect, each time I verified that the 'light' version was selected, are you certain that was the 'mode' you were in?

Also, it talks about having form based authentication, is that the case in your situation?
Maybe it is using one of the other methods of authentication?
0
serafiraCommented:
The response we got from Dell Gold support who theoretically contacted Microsoft was that it's a feature not a bug, they won't fix anything that is Exchange 2003 backend mailboxes and Exchange 2007 OWA.  We confirmed that users we migrate to Exchange 2007 mailboxes work correctly.  Problem is we are not ready to migrate all 10,000 users to Exchange 2007 mailboxes.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.