how to block web mail like gmail and gtalk

Dear experts:

I am having a winxp prof. now i have asked to block only gmail and block gtalk but not all others like yahoo and hot mail , please help me to do this.

Thanks in advance.
D_wathiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Are we talking a few machines, hundreds?
Domain/Workgroup?
Without a central Proxy/Web Content Filter, it would really be hard to do, unless you either provide a false DNS record for the GMail URL's, or use a local host entry...
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
D_wathiAuthor Commented:
Thanks for the reply , this is for one system which does not have a proxy and this is natted directly to the router , please help me  how to do the following:

provide a false DNS record for the GMail URL's, or use a local host entry...

Thanks in advance.
0
johnb6767Commented:
Single PC, probably dont need to worry about the DNS entry....
How to Modify the Hosts File to Block Bad IPs
http://www.associatedcontent.com/article/1197023/how_to_modify_the_hosts_file_to_block.html
Basic directions on how to edit the HOSTS file, to add an entry like the following......
127.0.0.1 mail.google.com

As for  GoogleTalk, I just installed it and it is trying to connect to 74.125.95.138 (dont have an account, might try multiuple IP's to connect to as a sort of Failover
Use TCPView from MS to determine where it connects....
TCPView
http://live.sysinternals.com/tcpview.exe
Now, with GoogleTalk, would probably be easier to either add a "DENY" entry for the following folder, in the NTFS permissions...
C:\Program Files (x86)\Google\Google Talk\
or for 32 bit
C:\Program Files\Google\Google Talk\
That way, when they try and launch it, they get an Access Denied. Of course if they are an Admin, then they can just modify the permissions if they figure out how....
If this is XP Pro, you can also look at the local Group Policy, which can block the launching of certian apps that you specifiy.....
DisallowRun
http://technet.microsoft.com/en-us/library/cc960900.aspx
HOW TO: Restrict Users from Running Specific Windows Programs in Windows 2000
http://support.microsoft.com/kb/323525
Link above should be the same for XP Pro
Is the User an Admin?
0
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

D_wathiAuthor Commented:
thanks for for the reply, request you to please tell me how to use group policy and block such webmail and chat applications, thanks in advance.
0
Tapan PattanaikSenior EngineerCommented:
0
johnb6767Commented:
From my above link.....
Editing the Local Policy on a Windows 2000-Based Computer To restrict users from running specific Windows programs on a standalone Windows 2000-based computer:
Click Start, and then click Run. In the Open box, type gpedit.msc, and then click OK. Expand User Configuration, expand Administrative Templates, and then expand System.
In the right pane, double-click Don't run specified Windows applications.
Click Enabled, and then click Show.
Click Add, and then type the executable file name of the program that you want to restrict users from running. For example, type iexplore.exe. Click OK, click OK, and then click OK.

NOTE: If domain-level policy settings are defined, they may override this local policy setting. Quit Group Policy Object Editor. Restart the computer.
 
 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Chat / IM

From novice to tech pro — start learning today.