Exchange 2007 Public Folders have disappeared

Posted on 2009-07-12
Last Modified: 2012-05-07
Our 2007 Exchange CCR Server has a Public Folder Storage Group, containing a Public Folders Database. the public folders cannot be seen or managed using the Public Folder Management Tool in Toolbox, but using the get-publicfolderdatabase cmd shows the correct database and storage group.
But if I use the get-publicfolder command, it says that there is no existing public folder.
The PF management Tool will not let me "Update Hierarchy" and says there is no Public Folder Database on the server.
The set-publicfolderdatabase command can change parameters such as MaxItemSize etc, but the Public Folders still do not seem to exist.
The Public Folders Address List still shows all of the expected Public Folders, and the database seems to be fine according to ESEUTIL. Any ideas anyone?
Question by:fixer982
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3

Expert Comment

ID: 24837973
LVL 40

Expert Comment

ID: 24838972
The Public Folders Address List shows only mail enabled public folders. Using connect to option connect to your server where you have PF DB and click on Default Public Folders.

Author Comment

ID: 24844926
Thanks Nivles

h but I'e already been there and it didn't help. When I bring up the PF Management Console, it just shows 2 folders, Default and System and when I try to create another folder, it says that theer is no Public Folders Database on teh Server. Buty when I try to create a new PF DB, it says there is already one.
Thanks Subsun, but as above, the PF MMC does not allow me to manage or create them. Its as if the Exchange Server and AD think that there is a PF DB, but cannot connect to it.
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 40

Expert Comment

ID: 24846314
Run this command to PF Hierarchy on your server and see if it helps..
Update-PublicFolderHierarchy -Server "Your Server"

Author Comment

ID: 24846463
Thanks again Subsun. I had already tried this as well, but I ran it again. The Public Folders are now visible, though I do not know why. However, running the Update-PublicFolderHierarchy command bring up the message "There is no public folder database on teh server "HPEXCHANGE". Yet when I run get-publicfolderdatabase, i get "Public Folders" (Name), "HPEXCHANGE" (Server) and "Public Folders Storage Group" (Storage Group). It seems there is a conflict with the settings somewhere which set the Public Folders location.
LVL 40

Expert Comment

ID: 24846493
Do you have a coexistence environment (Ex2003+Ex2007)? or only exchange 2007..
Do you have latest roll up update and critical patches installed?
Please run ExBPA and see if it gives any clue..

Accepted Solution

fixer982 earned 0 total points
ID: 24875054
Hi all,

I have posted this in case anyone else encounters this problem. I found that the msExchOwningPFTree attribute under the Public Folders Container was empty, even though all the other attributes were not set. I followed this atricle,, to remove and recreate teh folder hierarchy container and the affected CN-Public Folders container, and after checking all the attributes that were likely to affect the outcome, I restarted the IS on the CCR Mailbox Active Node and the Public Folders reappearred. Why this attribute changed is beyond me, but that's Exchange for you. This took 4 days to fix and wasted a lot of time, but the result was success in teh end.

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question