Need to run multiple arbitrary commands on multiple arbitrary hosts from one central host

I am looking for a package or perl programme which help me to run multiple arbitrary commands on multiple arbitrary hosts from one central host. However, i found something called as CSSH and PSSH but that doesn't seems to be working for Soalris 10 environment.

Hence, I would be greatful if anyone can help me to find out a reliable package which can be used in production environment and solve my purpose.
LVL 40
SubsunAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Hi,
there is 'dsh' (perl) -
http://dsh.sourceforge.net/
and 'dsh' (python) -
http://pydsh.sourceforge.net/
another version (don't know that one) -
http://www.netfort.gr.jp/~dancer/software/dsh.html.en
 
wmp
 
0
SubsunAuthor Commented:
Let me try, I will update you the status...
0
RowleyCommented:
Arbitrary commands to various different servers at different times? Manual or automatic arbitrary commands? For manual, how about puttycs?

http://www.millardsoftware.com/puttycs

Failing that, you could also look at rex (remote execution). If you want to keep things slightly more structured, I would shout about something like cfengine.

http://www.cfengine.org/

If none of these float your boat, then if you could be a bit more specific then maybe we could suggest something more suitable.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

SubsunAuthor Commented:
Thanks alot to all of you for helping me out with this query.

I tried to install Dsh and while compilation it throws error saying "checking for open_dshconfig in -ldshconfig... no configure: error: dshconfig not found!!" even i installed the libdshconfig-0.20.9 seperately but again it gives same error message.

As I am using Solaris 10 Sparc environment. Is there any specific package for this kind of environment which support and secure.

Cfengine sounds good to me, but it is paid and how about its usage?
0
RowleyCommented:
Cfengine is free and v2 downloadable as a package from sunfreeware.com. The documentation is excellent and it shouldn't take much to get it up and running. There is community and paid support if you need it, and it uses ssl to do its thing.

Docs tutorials et al:

http://www.cfengine.org/document.php
0
woolmilkporcCommented:
How much functionality do you actually need?
Wouldn't a tiny script like this be sufficient?
#!/bin/ksh
HOSTS=/list/of/hostnames
for host in $(cat $HOSTS | grep -v "^#")
 do
  echo "----------------" $host "----------------"
  ssh $host "$@"
done
0
SubsunAuthor Commented:
My requirement is something i am looking for a software/application which enable me to run commands or copy files at at time on a group of solaris servers. I am aware of the script but that is not permanent solution or much effective in my environment.
However I tried to install the CSSH and PSSSH and DSH but all giving me error messages..
0
cj_1969Commented:
Are you trying to do this from a Solaris workstation or do you have a Windows workstation that you can run this from?

Going back to the comment about PuTTY ...
this comes with a program called plink.  Using plink you can then create a script and execute a series of commands one each server.  Basically a batch file that executes the command against each server.
For copying files you could use scp (pscp on Windows) and again just script the copy process to run against each of the servers in question.

Do you have openSSH running on your server?  If not, then you will need to do this so that you can run the secure shells to connect to your servers to get this apps to work, as they are all secure connection programs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SubsunAuthor Commented:
The SSH port was blocked and in the configuration file of sshd_config it was blocked for root login.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.