Wireless router not getting IP from cable modem

We have Time Warner Roadrunner Broadband for our internet.

Our wireless router was no longer able to get an IP address from the modem, so we thought our router was bad and bought a new one. It worked for approximately 16 hours, now it, too, no longer gets in IP address from the modem.

If our computers are plugged directly into the modem, we can access the internet just fine. If our computers are plugged into the wireless router, we are unable to get to the internet. Checking the configuration settings on the router revealed that it is not receiving an IP address.

Any thoughts or suggestions?
mommie_geekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

regnighcCommented:
Whats the model of your wireless router? You should be able to renew/request an ip adress from your cable modem from the routers configuration page, but knowing the model will help me assist with that/
0
mommie_geekAuthor Commented:
It's a Linksys by Cisco WRT54G2.

We also tried renewing/requesting an IP address from the cable modem, but no address is ever assigned to the router.
0
regnighcCommented:
I would say the Router is to fault if you have already tried that.

Try Flashing to the latest firmware

You can download it here

http://www.linksysbycisco.com/US/en/support/WRT54G2/download

hope that helps
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

KIP HelpCommented:
You don't think it's something on Time Warner's end? Could they have set something up that stops it from passing IP addresses to wireless routers? I only ask because we had a netgear previously (as of yesterday at 4:30PM) that did the exact same thing which is why we went out and purchased the Linksys.
0
mommie_geekAuthor Commented:
Sorry, I logged in with my work account (above) instead of my personal account. The above post is from me, however.
0
regnighcCommented:
Its possible, im not sure as I'm from the UK however one of our major cable companies used to not allow routers, they would only allow devices that they had the MAC address registered of.

I would check with them first to see if its authorised, as they may still need to register the device with their service.

If it is authorised then I would follow the firmware upgrade route
0
mommie_geekAuthor Commented:
I'll keep the firmware suggestion in mind.

Is there anyone in the US who has specifically dealt with Time Warner/Roadrunner and wireless routers?
0
mommie_geekAuthor Commented:
The solution turned out to be found on Linksys's website. However, one of the solutions (that wasn't applicable) was to update firmware. I'm going to award full points for this. Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.