DCOM 10016 Event ID Error

I've got a Dell OptiPlex G620 having an error daily in the event log, and it seems whenever this error appears, it causes the machine to power down. I've seen different solutions to fix this problem but they all seem above my head as i'm not very familiar with regedit and registry. Can someone explain how to fix this problem in layman's terms?
Who is Participating?
ciphronAuthor Commented:
Thank you for the step by step. I've completed your instructions and will let you know if this fixes the problem sometime tomorrow.
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

*** Hopeleonie ***IT ManagerCommented:
could we help you?
ciphronAuthor Commented:
unfortunately his computer still powered off. The same error appeared too. This is exactly what it says:

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18).  This security permission can be modified using the Component Services administrative tool.
ciphronAuthor Commented:
Yesterday his computer did not shut down and i did not see the error code on his event viewer - same as today (so far). So i'm hoping that its fixed - maybe it just took a day to take effect for whatever reason. I will keep you posted.
Thanks for the update
ciphronAuthor Commented:
looks like this worked.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.