Web Config File in IIS7 Windows 2008 Needs A look at.

I am having trouble with my server.  I am Pretty new with IIS .
Could someone that deals with this stuff all the time look at this file,
Attached is my web.config file from my Root Dir.  Can you tell me if it looks normal, and how many of the web.config pages should I have in my root Dir  folder and above?

Regards and thank you,
Selvol

web config IIs7 winblows 2008 ASP
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
 
    <system.webServer>
        <defaultDocument>
            <files>
                <clear />
                <add value="Default.asp" />
                <add value="Default.htm" />
                <add value="index.htm" />
                <add value="index.html" />
                <add value="iisstart.htm" />
                <add value="default.aspx" />
                <add value="index.php" />
            </files>
        </defaultDocument>
        <directoryBrowse enabled="false" showFlags="Date, Time, Size, Extension" />
        <asp appAllowDebugging="false" codePage="1252" enableParentPaths="true" exceptionCatchEnable="true" scriptErrorSentToBrowser="false" bufferingOn="true">
            <limits bufferingLimit="4194304" />
            <comPlus appServiceFlags="EnableSxS" sxsName="True" executeInMta="true" />
            <session allowSessionState="true" />
        </asp>
        <cgi createProcessAsUser="true" timeout="00:15:00" />
        <caching>
            <profiles>
                <remove extension=".asp" />
                <add extension=".asp" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" duration="00:00:30" />
            </profiles>
         </caching>
 
    </system.webServer>
    <system.web>
        <compilation maxBatchGeneratedFileSize="1000" maxBatchSize="1000" />
        <globalization enableClientBasedCulture="true" />
        <identity impersonate="false" />
    </system.web>
</configuration>

Open in new window

LVL 17
selvolAsked:
Who is Participating?
 
Dave_DietzConnect With a Mentor Commented:
Your file looks normal.

In IIS 7.0 all of the configuration is held in .config files - ther eis no Metabase anymore.

At the very least there should be an applicationhost.config at c:\windows\system32\inetsrv\config\applicationhost.config.

It would not be out of range to see a web.config file in each directory of each website, although unless you are doing a lot of custom configuration I would expect more along a web.config at the root of the site and another at each application root with perhaps a couple extras sprinkled around.

CGI is typically resource heavy which is why CGI use is generally discouraged with IIS.  If you can use applciations that are FASTCGI compliant you can use the FASTCGI interface in IIS 7 (also installable under IIS 6) and get *much* better performance - order of magnitude or better improvement generally.

Classic mode vs. Integrated will be in the Applicationhost.config file but effectively it means the difference between .Net being used as a request handler accessed by making a request that includes one of its mapped extensions (Classic) vs. .Net being available from the front of the pipeline to the end of the pipeline (Integrated).  Is there a reason your are particularly concerned with this setting?

Dave Dietz
0
 
dhlevineCommented:
Hello -

What specifically is wrong with your server?
0
 
selvolAuthor Commented:
I have experienced some of my error pages not showing. CGI, running very HEAVY on the resourceds, A question about why its running in "ASP Classic" Mode.  Basically someone and of course not me, changing some  settings in en effort to do what I am not sure at the moment. There has been some performance issues.

 OS: Windows Server 2008 Web  Processor: 2.8GHz e7400   Ram: 4 GB

SElvol
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
selvolAuthor Commented:
Thank you I am will close this when I get back....

Regards,

Selvol
0
 
selvolAuthor Commented:
0
 
selvolAuthor Commented:
THank you............
0
All Courses

From novice to tech pro — start learning today.