Solved

SBS 2008 VPN DNS Issues

Posted on 2009-07-13
2
862 Views
Last Modified: 2012-06-21
I'm currently running a SBS 2008 Premium server with Windows XP Pro SP3 clients. I've encountered issues with the Microsoft VPN client since upgrading to SBS 2008. My clients are able to connect, authenticate, and get DHCP settings correctly. If servers are referred to by \\servername.domain.local\share it works great but if only \\servername\share is entered the VPN'd machines are unable to resolve it. Is this inherint within the design of SBS 2008 or is there something I can adjust to provide the ability of resolving by just the servername?
0
Comment
Question by:Danstr1
2 Comments
 
LVL 3

Accepted Solution

by:
AdoBeebo earned 500 total points
ID: 24841989
This is a guess, but are your VPN clients going into a different subnet to the rest of the domain? Are they pulling down 192.168.1.1/24 IP addresses? This IP range is provided by Networking and Remote Access. I haven't peered into the defaults of SBS08 but I do know that the DHCP service provided by N&RA is limited compared to the full blown DHCP service that will be handing out IPs to internal clients.
Can you check that it is the SBS08 server providing DHCP services from its own DHCP service, or if it is the limited DHCP service that comes with Networking and Remote Access Role. Check to see if DHCP leases are being provided to a logged in VPN client from the main scope, and verify the DNS settings are correct within the scope.
You can certainly help your aim of single name resolution by setting up a GlobalNameZone which is populated with CNAME values. If the GNZ is included in the same DNS as is specified for clients in the DHCP scope they use you should find name resolution a little bit smarter.
Setup GNZ
From CMD:
dnscmd.exe ServerNameHere /config /enableglobalnamessupport 1
In DNS Management
Create a new Forward Lookup Zone called "GlobalNames", AD integrated, replicate forest-wide.
Populate this zone with CNAME values e.g.
"SBS08" = "SBS08.domain.local"
"Proxy" = "ISA06.domain.local"
etc
0
 

Author Comment

by:Danstr1
ID: 24843250
The DHCP all checked out. DHCP was coming correctly from the server including the DNS settings. I proceeded to create the GlobalNameZone as you recommended. I am now able to connect to those machines I entered the CNAME values for. Thanks!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now