Solved

help syncing mail 4 exchange with sbs 2003

Posted on 2009-07-13
18
211 Views
Last Modified: 2012-06-21
hi all,

i'm trying to connect my phone to out sbs 2003 exchange with mail4exchange but keep getting the error

invalid mail for exchange xcredentials. check credential settings.

now the credentials are username = username i enter when in the office.
password = password i enter when in the office.

domain = static ip of the internet connection with port forwarding to the server.

now is there anything i can try to resolve this because as far as i can see everything should connect??

many thanks in advance,

Matt.
0
Comment
Question by:flynny
  • 10
  • 7
18 Comments
 
LVL 12

Expert Comment

by:Saakar
ID: 24841730
what are the authentication settings for /Exchange VDIR?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24841975
What is the Make / Model of the phone?
Have you tested your server configuration on https://testexchangeconnectivity.com ?
Use the Exchange Activesync test.
0
 

Author Comment

by:flynny
ID: 24848951
hi there thanks for the replies.

sorry it hought is added the phone is a n96.

ok i went to the link you provided and entered the following

> selected exchange active sync

filled in the details and the connectivity failed on testing the ssl certificate. now the domain name

Host name mail.<ourdomainname>.com does not match any name found on the server certificate CN=<differnetdomainname>.com, CN=companyweb, CN=<server name>, CN=localhost, CN=<servername>.<differnetdomainname>.local

now to just fill in the DNS that points to our static ip is e.g. mail.our-company.com. however the differnet domain name on the server is simply ourcompany.com (i.e. without the -).

any ideas on how i get around this?

thanks for all your help.

matt.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24849577
Did you issue the certificate (self-signed), or did you buy the certificate?
0
 

Author Comment

by:flynny
ID: 24850798
its self signed, which i have now changed to match our domain name.

ok we get a bit further now i get the error

A Web Exception occured because an HTTP 401 - Unauthorized response was received from Unknown

when trying to active sync with the server?

any ideas?

thanks again,

Matt.
0
 

Author Comment

by:flynny
ID: 24850810
sorry this error occurs at this point of testing

Attempting to send OPTIONS command to server
 Testing the OPTIONS command failed. See Additional Details for more info
0
 

Author Comment

by:flynny
ID: 24851034
apologies, i'd entered the domain name incorrectly!.

ok it connects fine through here, but still not through the mail 4 exchange? any ideas why?
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 24851067
Can you list the Authentication / IP Restrictions / SSL requirements / Domains and Realms of the following 4 IIS Virtual Directories under the Default Website please and also the ASP.NET version they are set to use.
  • Microsoft-Server-Activesync
  • OMA
Open up IIS - Expand the Default Web Site.  Right click each virtual directory and select properties.  Click on the Directory Security Tab and then list the contents from each of the three buttons per Virtual Directory.  Then check the ASP.NET tab.
Thanks
0
 

Author Comment

by:flynny
ID: 24885793
Hi alan thanks for the reply again,

ok i rebooted the sbs server and tried to connect using the same credentials and this time i got further.

its prompts about the certificate being 'website has sent a certificate with different website website name than requested. accept anyway?'

i select accept permanently.

i then get the message future connections to .... will be made without certifi warning. continue.

to which i select yes. i then get the error 'system error. please try again later.'

to answer your questions before

Microsoft-Server-Activesync (under the directory security tab)

Authentication - basic authentication (sent in clear text) with the default comain being the domain i connect to)
IP Restrictions - by default all computer are granted access.
SSL requirements - ignore client certificates is selected

OMA

Authentication - basic authentication (sent in clear text) with the default comain being the domain i connect to)
IP Restrictions - by default all computer are granted access.
SSL requirements - ignore client certificates is selected

sorry, what do you mean by check the ASP.NET tab?

many thanks again,

matt.
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24885810
Okay - thanks for the update.
Sounds like your certificate is setup incorrectly.
What is the name on the certificate - check in IIS - Default Website properties, Directory Security Tab, View Certificate.
If this is not the FQDN that you are using to connect via Activesync with e.g., mail.yourcompany.com, then you need to re-issue the certificate.  For SBS - re-run the Connect to the Internet Wizard - Start Server Management - To-Do List.
There should be an ASP.NET tab under IIS Virtual Directory properties.  If not, then I don't think it's a show stopper.
Change the certificate and try again - you may just find that it works!  If not - come back for other steps.
Alan
0
 

Author Comment

by:flynny
ID: 24885863
no problem thank you for all your help.

just to give the full details under IIS i go to <name of server computer> (local computer) -> websites ->default website

ok i have an aspnet_client directory? is this the one?

Authentication - enable anony access is ticked, as is intergated windows authentication
IP Restrictions - by default all are denied access except the serverand 127.0.0.1 (??) .

regards the certificate -> i have issued by mail.<domain name>.com issued to mail.<domain name>.com so iassume that this should resolve ok as mail.<domain name>.com is the points to the static IP of the router which forwards onto the server.

thanks again,
matt.
0
 

Author Comment

by:flynny
ID: 24885873
sorry juat read the comment properly, no i dont think i have the ASP.NET tab under IIS properties???

i assume .NET is installed though?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24885884
Re-test on https://testexchangeconectivity.com and see where you get - you will probably have to ignore the SSL check by ticking the box.  Self-signed certs fail all the time.
0
 

Author Comment

by:flynny
ID: 24885939
hi there yes it connects through this ok (if i select the ignore trust tick box)
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24885950
Okay - so you should be good to go.
Have you wiped the exchange account off the phone and set it up from scratch again?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24885960
Have you installed the certificate onto the phone yet?
0
 

Author Comment

by:flynny
ID: 24906792
sorry for the delay i'm going to run the mail 4 exchange on another phone and see how it works on that one as i'm getting the same error ill update as soon as ive done that.

thanks for all your help!
0
 

Author Closing Comment

by:flynny
ID: 31602890
thanks for all your help!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now