Improve company productivity with a Business Account.Sign Up


Problem printing to receipt printer using AS400 remote outq

Posted on 2009-07-13
Medium Priority
Last Modified: 2013-12-06
I am having issues printing to a receipt printer attached to PC. Printer out put is generated on an AS400 and sent to the printer via remote outq.
When the remote outq  is started I see the spool file on the AS400 get sent.
Nothing will print on the Ithaca 280 printer until I end the remote writer on the AS400.

We are using an Ithaca 280series receipt printer attached to PC running windows XP.
The printer is attached via parallel port. Drivers are installed and we can print a test page.
Additional information
Windows Support of TCP/IP printing is loaded and the service is started automatically.
Windows Firewall is off.
Printer is shared on the PC.
Shared name is ITH280.

Remote outq on the AS400 is set up as shown below:
 Output queue . . . . . . . . . . > P3            Name                  
   Library  . . . . . . . . . . .     *LIBL       Name, *LIBL, *CURLIB  
 Maximum spooled file size:                                              
   Number of pages  . . . . . . .   *NONE         Number, *SAME, *NONE  
   Starting time  . . . . . . . .                 Time                  
   Ending time  . . . . . . . . .                 Time                  
                + for more values                                        
 Order of files on queue  . . . .   *FIFO         *SAME, *JOBNBR, *FIFO  
 Remote system  . . . . . . . . .   *INTNETADR                          
 Remote printer queue . . . . . .   'ITH280'                            
 Writers to autostart . . . . . .   1             1-10, *SAME, *NONE        
Queue for writer messages  . . .   QSYSOPR       Name, *SAME              
  Library  . . . . . . . . . . .     *LIBL       Name, *LIBL, *CURLIB      
Connection type  . . . . . . . .   *IP           *SAME, *SNA, *IP, *IPX...
Destination type . . . . . . . .   *OTHER        *SAME, *OS400, *OS400V2...
Host print transform . . . . . .   *YES          *SAME, *YES, *NO          
Manufacturer type and model  . .   *IBM42011                              
Workstation customizing object     ITH280        Name, *SAME, *NONE        
  Library  . . . . . . . . . . .     QSYS        Name, *LIBL, *CURLIB      
Image configuration  . . . . . .   *NONE         *SAME, *NONE, *IMGA01...  
Internet address . . . . . . . .   '    '                is the IP address of the PC the receipt printer is attached to.
The Workstation customizing object is a copy of *IBM42011 that is slightly modified.
Form feed was changed to CR LF.......
Any ideas?
Question by:VWPOS
LVL 36

Expert Comment

by:Gary Patterson
ID: 24845102
I'm not sure if I understand what is happening.  You send several print files from the AS/400, they disappear from the outq, but nothing prints on the receipt printer, then you end the writer on the AS/400 and what happens?  

They all print?

What happens on the XP machine?  When do the documents show up on the XP print queue for the printer?  What status do they show?

Before spending a lot of time troubleshooting, make sure you are running properly patched code at both ends:

What AS/400 OS version and PTF level are you running?  Make sure you are current on PTFs.
What XP Service Pack are you running?  Make sure you are running XP SP3.

- Gary Patterson
LVL 34

Expert Comment

ID: 24847343
Whenever I had such setups I always replaced the XP connection with a parallel to ethernet converter like this one

this makes the printer independent of the PC and provides it with its own IP address.


Author Comment

ID: 24849228
I send several documents from the AS400. They disappear from the outq.
Nothing will appear in the XP printer Q or for that matter print  until I end the writer on the AS400

I am running on old OS400 V4R4M0. PTF level TL00350 My issue is that we have 500 plus small AS400's. Over the years they have been very reliable but OS upgrades would mean replacement and/or disk and memory upgrades which were deemed not cost effective.

XP machine is at SP3

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

LVL 36

Expert Comment

by:Gary Patterson
ID: 24852383
Wow, that is pretty old.  There is one more CUME PTF for V4R4: TL01072, from Mar 19, 2001.  I'd suggest that you apply this cume PTF (or if one of your 500 AS/400's has it installed, test there and see if you have the same problem) before we spend a lot of time trying to diagnose a problem with unpatched code.

If the problem is with the LPD client on Windows, then shalomc's idea sounds good (though if you have to do this for 500 locations, that might be cost-prohibitive).

Does this configuration work anywhere in your network, or is this a new configuration?

End the writer, and then try using the SNDTCPSPLF command.  What happens?

- Gary Patterson

Author Comment

ID: 24873015
I am having trouble finding the latest cum for V4R4... Any suggestions?

I tried SNDTCPSPLF and received:
TCP 3405
Not able to send the specified data
LVL 36

Expert Comment

by:Gary Patterson
ID: 24874258
Do you work with an  IBM Business Partner?  They might be able to help you obtain this old CUME.  Did you try using the SNDTCPORD

Was the writer ended when you tried SNDTCPSPLF?

Just to be safe, post the exact SNDTCPSPLF command you used.  You can get the TCP3405 error if the destination queue name is incorrect.  (which is case sensitive).  The TCP3405 error message isn't consistent with your original problem.

Here's IBM's troubleshooter for this issue.  Post back if you need more help.  Remember that you are using LPR on the AS/400 to print to LPD running on Windows.

- Gary Patterson

Author Comment

ID: 24897606
I check my command and it did have a case issue. The writer is stopped. SNDTCPSPLF sent the file successfully but on the XP PC there were no documents in the print queue. In the system event log there was an entry
Event ID 4010 Request from (AS400) could not be satisfied: possibly due to network problem. Microsoft had the error listed but under windows 2000 and said to apply latest service pack. SP3 is installed for the XP PC I am using.
LVL 36

Expert Comment

by:Gary Patterson
ID: 24898016
Looks like you may have a network problem or a print driver proble,  

Are the AS/400 and the printer on the same subnet?  If not, check the routers at both ends and see if you are dropping packets.

Are you running Windows Firewall?  If so, do you have proper exceptions in place for LPR.LPD from the AS/400?  Try temporarily disabling Windows Firewall and see if the situation changes.

Make sure that you are running the latest driver for the printer, and that it has passed Windows logo testing for XP.  If it hasn't, this just might not be a good choice of printer to use with XP.  You may need to work with the driver manufacturer on this issue.

Download Wireshark and do a packet capture of traffic between the AS/400 and the XP machine during a SNDTCPSPLF with the writer ended.  Post the capture here (check the capture for user ids, passwords, etc, and edit those out first, of course).

- Gary Patterson

Author Comment

ID: 24965568
We have changed directon. I created a client access printer session and have the printer working. Thanks for your help
LVL 36

Expert Comment

by:Gary Patterson
ID: 24965677
Glad you were able to get it working!

- Gary Patterson

Accepted Solution

ee_auto earned 0 total points
ID: 34281147
Question PAQ'd and stored in the solution database.

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Just about everyone has an old PC laying around.  Ask anyone in the IT industry, whether they are a professional or play in it as a hobby.  From outdated Desktops to cheap "throwaway" laptops, they are all around and not as hard to "fix up" as you m…
The article covers five tools all IT professionals should know about, as they up productivity by a great deal!
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

605 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question