Solved

Ubuntu SSH - Install and enable php5-mcrypt

Posted on 2009-07-13
2
4,181 Views
Last Modified: 2013-12-06
Hi There,

I'm running Linux 2.6.9-023stab048.6-enterprise
My OS is - Ubuntu 8.04 LTS

I have access via Shell Command Promt and have saved the following sources to the sources.list file:

deb http://autoinstall.plesk.com/ubuntu/PSA8 hardy all
deb http://archive.canonical.com/ubuntu hardy partner
deb-src http://archive.canonical.com/ubuntu hardy partner
deb http://packages.dotdeb.org/ stable all


I executed the following line and the shell prompt returned a message saying the packaged was saved :

wget http://packages.dotdeb.org/dists/stable/php5/binary-i386/php5-mcrypt_5.2.9-0.dotdeb.2_i386.deb

Now I'm stuck!?

How do I install php5-mcrypt from here?

Many thanks in advance
0
Comment
Question by:wilson1000
2 Comments
 
LVL 14

Accepted Solution

by:
fmarzocca earned 500 total points
ID: 24843779
Add these lines in your /etc/apt/sources.list file:

#####################################
deb http://archive.ubuntu.com/ubuntu/ hardy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu hardy-security main restricted universe multiverse
##################################################

Then run

sudo apt-get update
sudo apt-get install php5-mcrypt

0
 
LVL 4

Author Closing Comment

by:wilson1000
ID: 31603003
Thank you fmarzocca, your solution was superb! Thanx again for your guidance!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now