Solved

Presence not working in OCS 2007 R2

Posted on 2009-07-13
2
3,519 Views
Last Modified: 2013-11-29
Hi,

I have a new install of OCS 2007 R2. The server is working ok (without any errors) but from the office communicator client, if I search for a contact, it shows the contact. But the contact does not show online. If I hover over the contact, it says "Cannot get presence for this contact".

If I search for sip:Emailaddress, it comes up fine and I can chat fine.
Any ideas?

0
Comment
Question by:knightrider2k2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 6

Accepted Solution

by:
adamg12345 earned 500 total points
ID: 24844398
Hi,

The times I have seen issues like this in the past have been with the address book.

The Address Book only updates once every 24 hours, so if it has not ran since you have created the users it can create this type of issue; the other time I have seen it is were the address book had become corrupt and the address book needed to be reset.

The first thing to try is to re-generate the address book and then force the download to the client.

This is doing by running abserver -syncnow from CMD on the Front End Server, if memory abserver is located at c:\program files\microsoft office communications server 2007 r2\server\core, or something close.

It usually takes 5 minutes or so to run the generate, you will need to check the event log to see when it has completed.

You will need to exit MOC and then delete the GALContacts.db file from your client, this is located in %userprofile\local settings\application data\microsoft\communicator, if I recall correctly, if not it can be searched.

I do not have a system in front of me to check.....

You will then need to fire up MOC again and the file should re-download.

I think this will fix your issue, and I hope it makes sense.

Adam
0
 
LVL 7

Author Comment

by:knightrider2k2
ID: 24845199
That Worked!

Thank you Adam
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip is around source server preparation. No migration is an easy migration, there is a…
Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question