Solved

how to install openfiler on CentOS 5.3

Posted on 2009-07-13
13
4,778 Views
Last Modified: 2013-12-15
Hi,

I have centos 5.3. I would like to install openfiler on this machine to configure a VA. Please, can someone show me the comand to install openfiler using yum?

Thanks,
0
Comment
Question by:vielkacarolina1239
  • 7
  • 5
13 Comments
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 500 total points
ID: 24845424
Hi,

OpenFiler is a separate distro. Though it is based on CentOS it is not CentOS anymore. So you'd either install CentOS form the ISO on an empty hard-disk or you can get an iso for virtual host or tarball if you use xen for that matters.

So there's no way to install Openfiler over an existing CentOS installation.

Cheers,
K.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24845455
When it comes to installation over the VA what Virtualization software will you be using ?
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24845458
What about your Hardware? Are you using a H/W raid adapter ?
0
 

Author Comment

by:vielkacarolina1239
ID: 24855507
Hi,

I have manage to install openfiler-2.3.x86-64 on a box. When the OS starts and it finishes probing devices at start up, It prompts me to log on. I am getting the command window to log on. What I mean is that I am not getting the graphical user interface after the computer boots up.
Please, can you help me identify the problem so that the computer will boot into graphical mode instead of command window?

Thanks,
0
 

Author Comment

by:vielkacarolina1239
ID: 24855684

would it be better if you show me how to install the tarball than trying to figure out why openfiler os is not supported on graphical mode on my machine?

If yes, please, could you tell me what I would need to do?
example,
1)download and install xen os.
2) configuring and installing tarball.

thanks,
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24855741
> I am getting the command window to log on. What I mean is that I am not getting the graphical user
> interface after the computer boots up.
> Please, can you help me identify the problem so that the computer will boot into graphical mode instead of > command window?

It won't!!! OpenFiler is a specialised distro and there's nothing to do with GUI. Once boot-up you'll need to connect it through GUI to customize it.  It does not have a GUI to acess it like Regular Linux distro.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24855766
> would it be better if you show me how to install the tarball than trying to figure out why openfiler os is
> not supported on graphical mode on my machine?

If yes, please, could you tell me what I would need to do?
example,
1)download and install xen os.
2) configuring and installing tarball.

Here are the detailed How-to on Xen tarball installation.
https://forums.openfiler.com/viewtopic.php?id=3489

Note that you will have an OpenFiler appliance (Virtual Guest) when finished it won't have a GUI either since OpenFiler has no GUI. Instead there's a built-in web server and you configure the OpenFiler over it.  Just as your ADSL modem at home. Though it runs Linux it  does not have an X GUI but you configure it over the embedded web server.
0
 

Author Comment

by:vielkacarolina1239
ID: 24855967
Thanks, I was breaking my head trying to figure out why this thing would not boot into graphical mode.

Please, could you help me configure the server that allows access to open filer?
openfiler is running on 192.168.0.3:446 and the screen I am seeing has the following.

The screen I am seeing says


Welcome to openfiler NSA, Version 2.3
Web administration GUI: 192.168.0.3:446

localhost login: root
Password: *****



When I tried to access 192.168.0.3:446 from another computer on the same network through a browser, I am getting the following message - please, go to code snippet.

 
Could you help me configure openfiler server/service on the local computer that is running on? Jjust so that I have a taste for it.


thanks,




Secure Connection Failed
 

192.168.0.3:446 uses an invalid security certificate.
 

The certificate is not trusted because the issuer certificate is not trusted.

The certificate is only valid for localhost
 

(Error code: sec_error_untrusted_issuer)

        

    * This could be a problem with the server's configuration, or it could be someone trying to impersonate the server.
 

    * If you have connected to this server successfully in the past, the error may be temporary, and you can try again later.
 

          Or you can add an exception&

Open in new window

0
 
LVL 30

Assisted Solution

by:Kerem ERSOY
Kerem ERSOY earned 500 total points
ID: 24856097
Hi,

Since the certificate the openfiler uses is self-signed so it is obvious that it is not tailored to your network. So it is normal that you get this certificate error. please ignore it. if you want to avoid it just add an exception on your browser (firefox) or add the certificate to your certificate store (Explorer)
0
 

Author Comment

by:vielkacarolina1239
ID: 24856180
Ok,

how would I continue to access the server when I get the above certificate message. Please, could tell me what I would need to do to move forward?

Thanks,
0
 

Author Closing Comment

by:vielkacarolina1239
ID: 31603051
thanks
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24857682
In fact the rest is very straight forward. When You'l get to the config screen you will see that all options are listed through GUI. If you have trouble about implementing something please go ahead and search the forum. Since the Documentation is a priced extra many people prefers to to search forums and there are so many good how-to's. Please don't forget to search the forum when you need something here:

https://forums.openfiler.com/

If there are some issues that you can't handle you can always open a new question here.

Cheers,
K.
0
 

Expert Comment

by:awcweb
ID: 24905609
You need to either tell your browser to ignore the certificate error or to accept the certificate;  it really depends on the web browser you are using.

The usual GUI login credentials are:
Username:  openfiler
Password:  password

0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now