Solved

outlook 2007 out of office does not work

Posted on 2009-07-13
24
576 Views
Last Modified: 2012-05-07
Hi ,
I have a exchange 2007 64bits installed on windows 2003.
and run the outlook 2007 as client .

I cannot set up the out of office assistance  in outlook , but I can set it up at webmail

I have SSL installed as webmail.domain.com.au

when I try Test Email autoconfiguration and type my email
name@domain.com.au and my password
I get "auto configuration was unable to determine your settings"

But I can send and receive email very well.

any help ??
0
Comment
Question by:GordonLiq
  • 12
  • 6
  • 5
  • +1
24 Comments
 
LVL 23

Expert Comment

by:debuggerau
ID: 24845216
Check in outlook under the File menu option for the offline option, check it is not checked..

0
 

Author Comment

by:GordonLiq
ID: 24845220
It is not checked
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24845241
You need to ensure Autodiscover is working for Out of office to work.

Since you said Autodiscover test is failing, check out the below article which will help you to configure Autodiscover,

http://www.exchange-genie.com/2007/07/exchange-2007-autodiscover-service-part-1/
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:GordonLiq
ID: 24845286
It does not help . all pictures are lost and I canot get many clue.

I only have on exchange 2007 server with default CAS and default HUB.
when new user configure the outlook 2007 account , they can get the account setting automatically.
0
 
LVL 13

Expert Comment

by:lastlostlast
ID: 24845320
Is the name of the Exchange Server able to resolve in internal DNS?
Try to browse "https://FQDN of exchangeserver/autodiscover/autodiscover.xml" from the client machine.

You will need to get the 'autodiscover' to work first and only then you will be able to set the OOF using Outlook clients.

Also when you run Test Email auto confiigure, make sure you uncheck 'Use Guess Smart' and 'Use Guess Smart Authentication'.
0
 

Author Comment

by:GordonLiq
ID: 24845339
Is the name of the Exchange Server able to resolve in internal DNS?

Try to browse "https://FQDN of exchangeserver/autodiscover/autodiscover.xml" from the client machine
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24845341
Hi Gordon,

Even though Outlook configures profile automatically, it doesnt mean autodiscover is working, Cause Outlook 2007 has the functionally to configure on its own.

So the bottom line is, the test Email autoconfiguration should pass.

Can you re-run the Test Email Autoconfiguration and then take a screen shot of the Log tab and paste it over here.
0
 

Author Comment

by:GordonLiq
ID: 24845345
Is the name of the Exchange Server able to resolve in internal DNS?
  Yes , both   exserver.domain.local  , exserver  , exserver.domain.dom.du work
Try to browse "https://FQDN of exchangeserver/autodiscover/autodiscover.xml" from the client machine
  where I can find FQDN of exchangeserver/autodiscover/autodiscover.xml"?
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24845370
"exserver.domain.local" is the FQDN of the Exchange server and when you browse the URL "FQDN of exchangeserver/autodiscover/autodiscover.xml", you should get an XML file loading with Error code 600.
0
 
LVL 13

Expert Comment

by:lastlostlast
ID: 24845382
By FQDN I meant, Fully Qualified Domain Name of Exchange Server.... Also let us know the results of Test Email Auto Configuration...
0
 

Author Comment

by:GordonLiq
ID: 24845464
Yes , I get an error says : no elemnet in that file.


here is the content of that xml file

<?xml version="1.0" encoding="utf-8"?>
<Autodiscover>
<!-- This is a placeholder file -->
</Autodiscover>
0
 

Author Comment

by:GordonLiq
ID: 24845479
lots of
autodiscover to https://mail.domain.com.au/autodiscover/autodiscover.xml failed in the log of test autoconfiguration
0
 
LVL 13

Expert Comment

by:lastlostlast
ID: 24845513
paste from the "Log" tab and not from the XML tab... that is where we come to know which URL it is failing to connect...
0
 

Author Comment

by:GordonLiq
ID: 24845521
this is the page result:

XML Parsing Error: no element found
Location: https://webmail.rpccare.com.au/autodiscover/autodiscover.xml
Line Number 1, Column 1:


log.jpg
0
 
LVL 13

Expert Comment

by:lastlostlast
ID: 24845581
In the IIS manager, go to properties of autodiscover, under 'directory security' click on edit button under 'IP address and Domain name Restrictions'... If you have it selected for denied access then change it to granted access...
0
 
LVL 9

Accepted Solution

by:
Raghuv earned 250 total points
ID: 24845585
Hi Gorden,

To fix the issue "<!-- This is a placeholder file -->",

You need to recreate the Autodiscover virtual directory, so run the below two commands on the Exchange Management Shell,

PS: I have mentioned "exserver" as NetBIOS name of the Exchange server.

# Remove-AutodiscoverVirtualDirectory -Identity "exserver\Autodiscover (Default Web Site)"

# New-AutodiscoverVirtualdirectory
0
 

Author Comment

by:GordonLiq
ID: 24845607
Is recreate need to restart or other effect? like user cannot get email or so.

how long it will be?
0
 
LVL 13

Assisted Solution

by:lastlostlast
lastlostlast earned 250 total points
ID: 24845626
It does not take much time to re-create the directory and there is no restart requirement......
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24845633
No, it wont cause any downtime. I mean users will not be affected and you will not have to restart the Server...you just need to run those two commands and then try to browse the URL again "exchangeserver/autodiscover/autodiscover.xml" and ensure you get an XML file with Error code 600
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24845635
And it will not take more then 2 minutes :)
0
 

Author Comment

by:GordonLiq
ID: 24845714
I get error code 600 now!
what is next?
0
 

Author Comment

by:GordonLiq
ID: 24845727
and the email test works too.
0
 

Author Comment

by:GordonLiq
ID: 24845969
but I still  cannot set up the out of office assistance  in outlook , but I can set it up at webmail
0
 

Author Closing Comment

by:GordonLiq
ID: 31603086
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This video discusses moving either the default database or any database to a new volume.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question