Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 961
  • Last Modified:

Cannot login to OWA (Outlook Web Access)

Hi Guys,

We have 1 user who cannot seem to login to OWA. I have tried ticking allow inheritable permissions in the security tab in AD and this was already ticked. I checked in exchange 07 to see if OWA was enabled and it is. We have migrated from Exchange 03 to 07 earlier this year and everything went ok. The user was able to use her webmail fine but it just stopped working all of a sudden. I checked to see that she is not part of the admins group as this overides the permissions. I also checked her AD settings and security settings against my AD account and they are Identical and yet I can still access OWA fine. she gets the following error message:

Request
Url: https://mail.domain.com/lang.owa
User host address: 0.0.0.0

Exception
Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException
Exception message: There was a problem accessing Active Directory.

Call stack

Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostLocally(OwaContext owaContext, OwaIdentity logonIdentity, CultureInfo culture, String timeZoneKeyName, Boolean isOptimized)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostRequest(OwaContext owaContext)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)
System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Inner Exception
Exception type: Microsoft.Exchange.Data.Directory.ADOperationException
Exception message: Active Directory operation failed on servername.childname.root.domain.com. This error is not retriable. Additional information: The name reference is invalid. This may be caused by replication latency between Active Directory domain controllers. Active directory response: 000020B5: AtrErr: DSID-03152392, #1: 0: 000020B5: DSID-03152392, problem 1005 (CONSTRAINT_ATT_TYPE), data 0, Att 200ee (publicDelegates)

Call stack

Microsoft.Exchange.Data.Directory.ADSession.AnalyzeDirectoryError(PooledLdapConnection connection, DirectoryRequest request, DirectoryException de, Int32 totalRetries, Int32 retriesOnServer)
Microsoft.Exchange.Data.Directory.ADSession.ExecuteModificationRequest(ADRawEntry entry, DirectoryRequest request, ADObjectId originalId)
Microsoft.Exchange.Data.Directory.ADSession.Save(ADObject instanceToSave, IEnumerable`1 properties)
Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()

Inner Exception
Exception type: System.DirectoryServices.Protocols.DirectoryOperationException
Exception message: A value in the request is invalid.

Call stack

System.DirectoryServices.Protocols.LdapConnection.ConstructResponse(Int32 messageId, LdapOperation operation, ResultAll resultType, TimeSpan requestTimeOut, Boolean exceptionOnTimeOut)
System.DirectoryServices.Protocols.LdapConnection.SendRequest(DirectoryRequest request, TimeSpan requestTimeout)
Microsoft.Exchange.Data.Directory.PooledLdapConnection.SendRequest(DirectoryRequest request, LdapOperation ldapOperation)
Microsoft.Exchange.Data.Directory.ADSession.ExecuteModificationRequest(ADRawEntry entry, DirectoryRequest request, ADObjectId originalId)

I have been through countless forums and websites to find an answer. Some people have the same issue and havent found a resolution.

Any help would be appreciated guys thanks.
0
BMPX
Asked:
BMPX
1 Solution
 
SubsunCommented:
Is the user able to mailbox using outlook?
Check this..
http://support.microsoft.com/kb/941146
Still not working then..
Try moving the user to another mailbox store and see if it helps..
0
 
Girish_2500Commented:
SEE THIS :
http://support.microsoft.com/kb/941146


Refer IIS logs on CAS server for the Problem user.

Start > Run > Logfiles > W3svc1

Take LDP dump of a User whose OWA is working with the Problem users.

http://support.microsoft.com/kb/224543
By comparing both User dumps you can find the difference.
0
 
BMPXAuthor Commented:
I fixed the issue by recreating the mailbox. None of the above worked but thanks for your help guys.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now