LEI 6.5 installation problem (cannot find server)

I'm installing LEI 6.5 on the same machine where the Domino 6.5 is running (on Win2003 server).
Although I can ping the server, LEI installer reports:
     "Your specified Domino server is not currently available. Please make sure the Domino Server is running or enter a valid server name."

I tried to enter IP address (with port also) instead of server name but that also didn't work.
I found out that dctest.exe is used when installing LEI in order to establish whether a server is available.

This is what dctest reports:
14.07.2009 09:58:07   Directory Assistance failed opening Primary Domino Directory names.nsf, error: This database is currently being used by someone else.  In order to share a Notes database, all users must use a Domino Server instead of a File Server.
LVL 22
mbonaciAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sjef BosmanGroupware ConsultantCommented:
> This database is currently being used by someone else
That message makes me assume that you installed LEI IN the Domino server environment, since LEI apparently tries to open the names.nsf of the Domino server directly.

My experiences with LEI are not very recent, so all I can suggest is to read the help:
http://www-12.lotus.com/ldd/doc/lei/655/leiig.nsf

Suggestion: add the server's name to the hosts file.
0
mbonaciAuthor Commented:
How do you mean "in domino server environment", prereq for LEI is Domino. Also it requires Domino to be running when it's being installed.
I already tried adding server in hosts file.
By now I know LEI installation guide by hart :)

Thanks for your suggestions.
0
mbonaciAuthor Commented:
This really makes me crazy.
I'm thinking about installing Domino 8 over 6.5...
0
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

Sjef BosmanGroupware ConsultantCommented:
And you didn't make the same silly mistake as I did, namely to modify the server's Domino port? I once set a server to port 1353 instead of 1352; outgoing there's no problem but sending mail from an agent was impossible: the server wants to connect to itself, but doesn't know how to. It needed a connection document with the port specified to solve the problem.
0
akhafafCommented:
mbonaci,,,
Did you check the following similar cases ?????

On a Domino partitioned server environment:
http://www.ibm.com/developerworks/lotus/library/ls-LEI65_install/index.html

On this sismilar case on a UNIX OS
http://www-01.ibm.com/support/docview.wss?rs=0&q=1110645&uid=swg21110645&loc=en_US&cs=utf-8&cc=us&lang=en

Finally, this Directory Assistance related similar case
http://www-01.ibm.com/support/docview.wss?rs=463&context=SSKTMJ&dc=DB560&dc=DB520&uid=swg21280047&loc=en_US&cs=UTF-8&lang=en&rss=ct463lotus

I hope that using any of these suggested solutions works with you

Good Luck
0
mbonaciAuthor Commented:
Sjef, I haven't changed domino NRPC default port (I tried even adding TCPIP_TCPIPAddress param with port with no success).
Also, I already have connection document with same source and destination server.
What's your suggestion on procedure of upgrading server to 8.0?


Akhafaf,
I tried first couple of pages of google results...
0
mbonaciAuthor Commented:
Do you think the problem may be that Data and Domino dirs are on different disk partitions?
I don't think this should be the problem since Notes.ini contains params named NotesProgram and Directory with correct paths.
0
Sjef BosmanGroupware ConsultantCommented:
I suppose it's not a problem, but with LEI one never knows.

http://www-01.ibm.com/support/docview.wss?rs=0&q=1110645&uid=swg21110645&loc=en_US&cs=utf-8&cc=us&lang=en

http://www.ibm.com/developerworks/lotus/library/ls-LEI65_install/index.html
and search for "Confirming connectivity to the Domino server using dctest"

To move to 8.5: is it a production server, and for how many people. Can you take the risk of upgrading without making a backup? There's a 0.01% probability that things will go wrong, but you know Murphy...
0
mbonaciAuthor Commented:
I managed to solve the problem by killing Domino and starting it as a console (source: IBM Lotus R6/R7 forum).
One of the problems was that i was accessing server using Remote desktop, which prevents you to see any console applications.
I found out that you have to run remote desktop with param /admin in order to log into session(0).

After that I wasn't able to successfully verify the connection documents using ncontest.exe.
The error message was: "Error: Cannot load Connector Library 'notesei' ".
I managed to fix it by copying and renaming nnotes.dcx to nnotesei.dcx.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sjef BosmanGroupware ConsultantCommented:
I don't like the remote desktop... And I get the idea that the releases of LEI and Domino don't match. Nobody else before renamed that file, that is to say, I can't get any hit in Google.

See
http://www-10.lotus.com/ldd/eiforum.nsf/PlatformAllThreadedweb/682d2edb4b81044e8525728f0025e25c?OpenDocument

Problem solved, reward yourself!
0
Sjef BosmanGroupware ConsultantCommented:
You're too kind with the points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.