Remove unwanted updates from WSUS to free up some space

I have a server which recently crashed to a lack of space on the c:\ drive. After some investigation I found the SUSDB.mdf file was nearly 7GB in size.

I browsed to http://localhost:8530/wsusadmin/ and found that there were nerly 40000 updates on the system. I then went in and setup WSUS so that it only downloads the updates that we actually need. However I am still stuck with all these unwanted updates.

When I click on the updates tab, after a while I get an error saying something like "unable to contact database"

I have tried WSUSDEBUGTOOL.exe /tool:purgeunneededfiles. I get an error invalid tool.

I have also tried WSUSUTIL.exe deleteunneededrevisions. After some time I get a timeout error message.

I just want to delete all the stuff I done need. Any suggestions?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

O. PierruSystem adminCommented:

What version of WSUS are you running on your SBS ?

roy_battyDirectorAuthor Commented:
how do i find out?
O. PierruSystem adminCommented:
1/ Open the SBS console (manage server)

2/ Go to advanced management > Internet services (IIS) > Websites > WSUS Administration > right click WSUSAdmin and select the Browse command.

3/ To determine your version of WSUS look all the way at the bottom of the WSUS home page and you should see the build number ( if you are running WSUS2 SP1).
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

O. PierruSystem adminCommented:
Please remember : don't manage your WSUS settings from this page or else you may get a WSUS error (blue shield) in your daily repports.
roy_battyDirectorAuthor Commented:
Yes its WSUS2 SP1 -
DonNetwork AdministratorCommented:
First you should upgrade to WSUS 3.0

Then you can run the WSUS cleanup wizard


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonNetwork AdministratorCommented:

After you upgrade to 3.0 you will no longer be able to administer from a browser, you will need to use the MMC snap-in.

DonNetwork AdministratorCommented:
This may be of use to you prior to updating

WSUS Cleanup
roy_battyDirectorAuthor Commented:
I cant install wsus 3 due to lack of space due to the large SUSDB.mdf file.

When i try to run the wsuscleanup wizard from the cmd line I get the attached response.

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or ass
embly 'Microsoft.UpdateServices.Administration, Version=3.0.6000.273, Culture=ne
utral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system c
annot find the file specified.
File name: 'Microsoft.UpdateServices.Administration, Version=3.0.6000.273, Cultu
re=neutral, PublicKeyToken=31bf3856ad364e35'
   at WSUS_Cleanup_CL.Class1.Main(String[] args)
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\M
icrosoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure lo
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fus

Open in new window

DonNetwork AdministratorCommented:
Have you tried to update to 3.0??
This will take care of your problems.
Also follow this thread first to help with your large susdb.mdf 
roy_battyDirectorAuthor Commented:
I can't install 3.0 as I get an error saying that I don't have enogh space , like I said.

The linked page only really addresses the PDF file and not the mdf file which is the one causing the problem for me.
DonNetwork AdministratorCommented:
I realize you say you are low on space. How large are your .LDF files??
Did you try what was suggested from the link(Restart Service MSSQL$WSUS)?
If you can get enough space to upgrade then the tools will help.
Here's a great article on how you can regain space by other means as well. 
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.