Solved

Cisco 2600 Router behind ADSL router

Posted on 2009-07-14
17
671 Views
Last Modified: 2013-12-14
Hi Experts,

I am trying to setup a test network before I roll it out in production network.  Its on an ADSL connection

I have a cisco 2600 Router with no ADSL wic & an Integrated netgear router.  I want to use the netgear as the gateway to gain internet access since the 2600 only has ethernet ports

Would I just connect the netgear to the fastethernet WIC and use the netgear as the default gateway or are there more things I need to consider.

Thanks
AL
0
Comment
Question by:Thirst4Knowledge
  • 10
  • 6
17 Comments
 
LVL 7

Expert Comment

by:namol
ID: 24849060
You can pretty much do it as you listed. However, do you not have a dsl modem or is the netgear the device your isp gave you?
0
 

Author Comment

by:Thirst4Knowledge
ID: 24849859
Hi Namol,

Its a dsl router, its Integrated so there is an RJ11 port for the ADSL(WAN) connection and it has ethernet ports for the LAN.  This is the what we use in the UK.

Thanks
AL
0
 
LVL 16

Accepted Solution

by:
memo_tnt earned 500 total points
ID: 24850658
yes you can
assuimg your subnet 192.168.1.0/24
then on 2600 do the followingfastethernt 0/0
ip address 192.168.1.200 255.255.255.0
no shu
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1 >>> netgear IP (gateway)
!
BR
0
 

Author Comment

by:Thirst4Knowledge
ID: 24851341
Hi Memo,

I had a go just before I got your response, instread of putting the internal gateway address of the netgear router I put the external Gateway address as the Ip route and I was still able to ping the external adddresses which I find strange.

[Internet]---[Netgear 192.168.0.1]---[2600 192.168.0.2]

Here is my config:

 
!  
version 12.2  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname 2600_Router  
!  
logging queue-limit 100  
!  
memory-size iomem 15  
ip subnet-zero  
!  
!  
ip name-server xxx.xxx.xxx.xxx  (DNS server address provided by ISP)
ip name-server xxx.xxx.xxx.xxx  (DNS Server address provided by ISP)
!  
!  
interface FastEthernet0/0  
 ip address dhcp  
 ip nat outside  
 duplex auto  
 speed auto  
!  
interface Serial0/0  
 no ip address  
 shutdown  
 no fair-queue  
!  
interface FastEthernet0/1  
 no ip address  
 shutdown  
 duplex auto  
 speed auto  

ip nat inside source list 100 interface FastEthernet0/0 overload  
ip classless  
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx(External WAN address provided by ISP)  
ip http server  
!  
access-list 100 permit ip 192.168.0.0 0.0.0.255 any  
!  
line con 0  
 exec-timeout 0 0  
line aux 0  
line vty 0 4  
 login  
!  
end  


0
 
LVL 16

Assisted Solution

by:memo_tnt
memo_tnt earned 500 total points
ID: 24851394
yes because you are getting router ip and gateway through  a DHCP
interface FastEthernet0/0  
ip address dhcp
so, you can ping on both ways,, to do so ,, you need to assign a static IP as i posted before ...
try traceroute any extrnal network and check results ...
 
 
BR
0
 

Author Comment

by:Thirst4Knowledge
ID: 24851450
THis is my traceroute result:

Type escape sequence to abort.
Tracing the route to www.l.google.com (209.85.227.99)

  1 192.168.0.1 0 msec 0 msec 4 msec
  2 213.130.147.48 8 msec 12 msec 8 msec
  3 bdr5.lon-th1.as8401.net (195.82.97.237) 12 msec 12 msec 12 msec
  4 gi9-7.mpd01.lon01.atlas.cogentco.com (149.6.3.5) 12 msec 16 msec 12 msec
  5 te3-1.mpd02.lon01.atlas.cogentco.com (130.117.2.26) 12 msec 12 msec
    te2-1.3493.mpd02.lon01.atlas.cogentco.com (130.117.2.18) 12 msec
  6 google.lon01.atlas.cogentco.com (130.117.14.90) 12 msec 12 msec 12 msec
  7 64.233.175.25 12 msec
    64.233.175.27 12 msec
    64.233.175.25 12 msec
  8 72.14.232.134 20 msec
    66.249.95.170 24 msec 20 msec
  9 209.85.251.231 24 msec
    209.85.252.83 20 msec 24 msec
 10 209.85.243.101 28 msec
    209.85.243.93 36 msec
    209.85.243.101 32 msec
 11  *  *  *
 12  *  *  *
 13  *  *  *


0
 

Author Comment

by:Thirst4Knowledge
ID: 24851496
Also another question, is there any need for the Access-list and the IP Nat commands ?  The netgear router has NAT enabled so im not sure they are needed.

Saying that however I am going to put the 2600 router in our data center where we wont be using the netgear as Internet access is presented via Ethernet Cables (100Mbps connection)

I will obviosuly need to do access lists at that stage.
0
 
LVL 16

Assisted Solution

by:memo_tnt
memo_tnt earned 500 total points
ID: 24861652

you dont need the NAT if it's enabled on the netgear,,
but i recommend to use the cisco ACL it's much dynamic and useful for me..
may be the netgear is user friendly and easier if you are not familiar with Cisco !!
I wish everthing is solved and clear for you ...

BR
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:Thirst4Knowledge
ID: 24934416

Everything is cools so far thanks for your help. The only issue is I cant telnet to the router, it may be something to do with NAT (Being done by the netgear) I have setup telnet to be allowed on the netgear but I still cant get to the 2600 via telnet from the outside world any ideas would be appreciated ?

 Regards T4K
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 24937169
you are welcome any time
plz post your run config ?? remove passwords
can you telnet the router from inside ??
plus can you ping the router from outside??
 
BR
0
 

Author Comment

by:Thirst4Knowledge
ID: 24959207
Hi Memo,

Sorry for the late reply,

I can ping the external address but that address belongs to the external interface of the Netgear router, which is also doing the nat.  So the f0/0 interface on the 2600 is Directly connected to the Netgear and has an RFC1918 address.

I have attached the running config and the topology if it helps.

T4K
Lab.docx
0
 

Author Comment

by:Thirst4Knowledge
ID: 24959216
Just to add:

I cant telnet from the inside (PC directly connected to the netgear router on the 4 port ethernet module)
0
 

Author Comment

by:Thirst4Knowledge
ID: 24959262
Update,

The reason why I could not telnet from the inside was because the ethernet cable had been unplugged :s

so I can in fact telnet from the inside
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 24959313
:)
:)

things happen

so, everything is settled now ??
if you need more help ,, please post
BR
0
 

Author Comment

by:Thirst4Knowledge
ID: 24959690
Hi Memo,

I can now confirm that I can telnet both internaly onto the 2600 and externaly.

The problem was (with the external) that my firewall at work would not allow me to telnet to the 2600 but when I changed my default gateway to go out of another firewall I was able to telnet !!  must be a rule on the original firewall to block outgoing telnet or something ?

Thanks for all your help

T4K
0
 

Author Comment

by:Thirst4Knowledge
ID: 24959777
hmm only a 6.6 ?  why is a "Good" so low ?
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 24960098
that's fine..

you are welcome any time

BR
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now