Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

how to configure QOS in cisco 3800 & cisco 2600 router for point point videoconferencing

Posted on 2009-07-14
4
Medium Priority
?
713 Views
Last Modified: 2012-05-07
i have MPLS vpn between my four location and also using video conferencing.
but sometime due to bandwidth problem it is creating problem for videoconferencing.
my manager has decided to implement QOS for this.

please help me to implement QOS.
if i want to dedicate 512kbps or 1 mbps for the videoconferencing what should be the configuration for 3841 router?

AUTHORISED PERSON ONLY
 
User Access Verification
 
Username: prabhu
Password:
CISCO3845#sh run
Building configuration...
 
Current configuration : 4720 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname CISCO3845
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 0
no network-clock-participate wic 1
no network-clock-participate wic 2
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip domain name serailway.gov.in
ip name-server 10.41.2.3
ip name-server 218.248.240.208
ip name-server 218.248.240.135
no ftp-server write-enable
!
username railnet password 7 1317161B0702013E
username prabhu privilege 15 secret 5 $1$Dztw$wWmhUMO1Ed59BOCHh/eJq.
username balaji privilege 15 password 7 120D0D12151909053E
username satheesh privilege 15 password 7 120D0D1210041F17
!
!
!
interface Multilink1
 description "Multilink 4MB to RAILTEL"
 ip address 10.255.255.234 255.255.255.252
 shutdown
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface GigabitEthernet0/0
 description "Connected to Rail Lan Network"
 ip address 10.255.252.2 255.255.255.252
 ip access-group 10 in
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1
 description " This port is connected to WAN firewall "
 ip address 203.153.37.65 255.255.255.192 secondary
 ip address 10.41.2.1 255.255.0.0
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface Serial0/0/0
 description " This port is connected with KGP "
 bandwidth 2575
 ip address 10.255.255.174 255.255.255.252
 encapsulation ppp
!
interface Serial0/0/1
 description "This port is connected to ADRA"
 ip address 10.255.255.190 255.255.255.252
 encapsulation ppp
!
interface Serial0/0/2
 description "This port is connected to CKP"
 bandwidth 2575
 ip address 10.255.255.238 255.255.255.252
!
interface Serial0/0/3
 description " This port is connected with RNC "
 bandwidth 2575
 ip address 10.255.255.246 255.255.255.252
 encapsulation ppp
!
interface Serial0/1/0
 ip unnumbered GigabitEthernet0/0
 encapsulation ppp
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/1/1
 description "Connected with Fairly Place"
 bandwidth 100
 ip unnumbered GigabitEthernet0/0
 encapsulation ppp
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/1/2
 description " Connecteed with 64 kbps NKG circuit "
 bandwidth 80
 ip unnumbered GigabitEthernet0/0
 encapsulation ppp
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/1/3
 bandwidth 2575
 ip unnumbered GigabitEthernet0/0
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/2/0
 no ip address
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/2/1
 bandwidth 256
 no ip address
 encapsulation ppp
 shutdown
 clock rate 2016000
 dce-terminal-timing-enable
!
interface Serial0/2/2
 description *** MPLS INTERNET ***
 bandwidth 2575
 no ip address
 encapsulation ppp
 shutdown
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface Serial0/2/3
 description *** MPLS delhi ***
 bandwidth 2575
 no ip address
 encapsulation ppp
 shutdown
 no fair-queue
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
router eigrp 11
 redistribute static
 network 10.0.0.0
 network 20.0.0.0
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 11 subnets
 network 10.41.0.0 0.0.255.255 area 0
 network 10.255.252.0 0.0.0.3 area 0
 network 10.255.255.172 0.0.0.3 area 0
 network 10.255.255.188 0.0.0.3 area 0
 distribute-list 20 out
 distance 80
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.255.252.1
ip route 10.129.0.0 255.255.0.0 10.255.255.173
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 10 deny   10.41.30.254
access-list 10 permit any
access-list 10 permit 0.0.0.0 255.0.0.0
access-list 10 deny   any
access-list 20 deny   10.255.254.53
access-list 20 permit any
snmp-server community public RO
snmp-server enable traps snmp authentication linkdown linkup coldstart
snmp-server host 10.41.2.8 public
arp 203.153.37.66 0019.b9b2.f9ce ARPA alias
arp 203.153.37.75 0019.b9b3.c466 ARPA alias
tftp-server 10.41.5.99 alias c3845-ipbase-mz.123-14.T7
tftp-server nvram:\
tftp-server flash:c3845-ipbase-mz.123-14.T7.bin
!
control-plane
!
banner login ^C AUTHORISED PERSON ONLY ^C
!
line con 0
 password 7 045E0501062F494B1B0A0D0E130A01
 login local
 stopbits 1
line aux 0
 stopbits 1
line 1/0 1/15
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
!
scheduler allocate 20000 1000
!
end
 
CISCO3845#

Open in new window

0
Comment
Question by:DIPRAJ
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 29

Expert Comment

by:Jan Springer
ID: 24849855
On what port(s) and tcp or udp does your video conferencing run?
0
 
LVL 11

Author Comment

by:DIPRAJ
ID: 24852777
if i want to dedicate the same to a particular lan ip.....(ip of the vc)
0
 
LVL 29

Accepted Solution

by:
Jan Springer earned 1500 total points
ID: 24852925
change the percent to reflect the amount that you want divided by the total bandwidth.  this way, as you increase your bandwidth, so goes the amount for that service.

--------------------------------------------------------------------------------------
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 permit ip any 192.168.1.0 0.0.0.255

class-map match-any QOS
 match access-group 101

policy-map QOS
 class QOS
  bandwidth percent 20
 class class-default

int <interface>
 service-policy input QOS
 service-policy output QOS
0
 
LVL 11

Author Closing Comment

by:DIPRAJ
ID: 31603254
thanks
0

Featured Post

The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question