SSL Exchange 2007 SBS 2008 issues

Hopefully, I ask this correctly... I am running SBS 2008 Prem. Edition with Exchange 2007.  Its name is blserver.bl123.local . It defaulted and installed the remote.bl123.local during the install for rww etc.  I purchased an ssl for webmail.bl123.com.  (bl123.com is an example, however we own our domain.) Apparently I have accuqired some ssl issues that I am hoping someone can help me resolve.  I need to be able to access the active sync for treo phones, and now I am getting "The name on the security certificate is invalid or does not match the name of the site" on outlook 2007, internally.  What I think needs to hapen is to install the webmail.bl123.com as my exchange cert.. but Ive tried commands I saw on other posts in the exchange shell and I couldnt get anything to work.. This is the first experience with exchange 2007 and it is way diffrent lol.  PLEASE PLEASE help =P lol  
zelliotts189Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NpatangCommented:
FIrst make sure that you have bind the certificate sucessfully on the default web site.
Also make sure that you have installe dthe cert on the phones.
The name on the security certificate is invalid or does not match the name of the site" on outlook 2007, internally, the reason why you are getting  this is becuse the internal url's of the virtual directory doesn't match with the cert URL
see the article
http://support.microsoft.com/kb/940726
0
zelliotts189Author Commented:
Should the cert not be bound to SBS web Applications? that is where the exchange, exchweb, exchadmin, etc are located.  also owa is there also.
0
NpatangCommented:
you are talking 2 different erros.

FOR OWA simply right click on the Defult web site adn clisck bind settings and check wether you have bind the cert properly.

For secong isue I have already given the article
0
MesthaCommented:
How did you get the certificate in to the server? Through IIS manager, through the wizards or through PowerShell?

With Exchange 2007, it is no longer as simple as putting the certificate in to IIS manager and expecting it to work. The certificate is core to the function of Exchange, which the SBS SSL wizard takes care of.
I haven't got an SBS 2008 running at the moment, but i think if you run the SSL wizard you get an option to select an existing certificate and to put the name in. You need to do that. That should ensure that the server is configured correctly to take your certificate name.

Simon.
0
zelliotts189Author Commented:
I called microsoft and they corrected the issues for me.  FYI, server 2008 SBS Prem. uses web app virt directory instead of the default website.  the cert has to be bound to that site instead of the default website.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.