Delayed Write Fail

I'm running an SBS 2003 server.  Im using the windows backup program to backup to a Seagate eSATA 500 GB HD. I get the Delayed Write Fail sometimes when the backup is running.  I've read a lot about this problem, but I still can't seem to find an answer.  Microsoft said to adjust the SystemPages value in the registry to 7FFF, but it was already at C3000. Another site said to disable Write Caching on the HD, but the option to do so is grayed out.  Any suggestions?

Thanks
-Paul
LVL 4
paulfarmerIT DirectoryAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
theShaoConnect With a Mentor Commented:
Try the reg tweak outlined in the MS article here: http://support.microsoft.com/kb/904569 to disable write caching on the drive.
There is another way of doing this, but i can't remember it off the top of my head or find the article - this should do what you need though. No guarantee it will fix your initial problem, but it might help - let us know.
0
 
opnjCommented:
Spend some money and buy a real backup program?
0
 
paulfarmerIT DirectoryAuthor Commented:
I agree that-that backup program is not the best, but I'm not sure that is the problem.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
theShaoCommented:
The SBS Backup program in SBS 2003 is pretty capable to be honest, i wouldn't have thought it's that that's responsible - when you say the setting for write caching is greyed out, is this from right-click--> properties for the drive in device manager?
0
 
paulfarmerIT DirectoryAuthor Commented:
Yes.  I will attach a picture.
0
 
paulfarmerIT DirectoryAuthor Commented:
Here it is.  
seagatedrive.bmp
0
 
paulfarmerIT DirectoryAuthor Commented:
I'll give this a whirl.  I won't know if it worked or not until I go through a few backup routines.  I'll let you know if a few days.
Thanks
-Paul
0
 
paulfarmerIT DirectoryAuthor Commented:
Ok, as soon as I restarted the problem got much worse.  I not get a DWF almost everytime I try to access the drive or do any other functions on the drive.  However, that means that the suggested solution did have an effect.  Maybe the number should be bigger or smaller, what do you think?

-THanks
Paul
0
 
paulfarmerIT DirectoryAuthor Commented:
Any suggestions?
0
 
theShaoCommented:
Sorry for the delay, been on holiday. Is the drive now displayed in device manager as "optimize for quick removal"? This is odd, because it shouldn't be using delayed write on a drive marked for quick removal. The fact that it happens so frequently suggests the disk is losing it's conenction to the server - i know this is obvious stuff but have you tried with a different cable, or copying large files onto the disk from another machine? Can you copy a file of a few GB onto the disk from the server, or does it bomb out with the DWF errors?
0
 
paulfarmerIT DirectoryAuthor Commented:
I'll try the large file copy and a different (maybe shorter) cable.
0
 
paulfarmerIT DirectoryAuthor Commented:
This solution did not work at first, but now everything works great.   Thanks
0
All Courses

From novice to tech pro — start learning today.