Solved

Certificate for SMTP

Posted on 2009-07-14
9
613 Views
Last Modified: 2013-11-30
Can I use my current SAN certificate for SMTP?
I currently have a SAN certificate in place for Exchange and it works for POP3 and OWA, though when setting up POP3 accounts in outlook I receive the certificate warning message..alot. When I run the "get-exchangecertificate" cmdlet the services currently on my thumbprint for my certificate are "I, P, W" and "I, S" on the default exchange certificate. How can I get the S onto my created certificate and will this allow outlook to stop warning me?
0
Comment
Question by:GMSMRM
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 8

Expert Comment

by:Npatang
ID: 24850660
check the below mentione link it should not create any issues with outlook
http://technet.microsoft.com/en-us/library/aa997231.aspx

Also for your popr users getting cert erros make sure that the send connector and recieve connector have the same FQDN mentioned which the CERT is issued to
0
 

Author Comment

by:GMSMRM
ID: 24850754
I tried running the same command earlier and after I enter the command the ">>" appears and nothing happens.
0
 

Author Comment

by:GMSMRM
ID: 24850893
I looked on the Edge Transport server and there are 4 tumbprints of just "S" services. Probably from all the times a had re keyed the certificate. None of the thumbprints match the ones on the Exchange server.

But this shouldn't matter for client access right?
0
Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

 
LVL 8

Expert Comment

by:Npatang
ID: 24850931
0
 

Author Comment

by:GMSMRM
ID: 24851071
That didn't help at all.
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24851103
So when you run the command

Enable-Exchangecertificate -thumbprint  (yours certificate thumb print) -services "smtp"

Does it throw any errors ?
0
 

Author Comment

by:GMSMRM
ID: 24851265
I finally got it to work. I was trying to just enable the SMTP by running the command you gave. Nothing happened. What I did do that worked was using your command but including the other services ("POP, IMAP, IIS") with the command and is asked me if I wanted to overwrite the default SMTP Exchange certificate.

Enable-Exchangecertificate -thumbprint  (yours certificate thumb print) -services "POP,IMAP,IIS,SMTP"

Here is the screenshot of the process.

Thanks.
exchange-cmd.bmp
0
 
LVL 8

Accepted Solution

by:
Npatang earned 500 total points
ID: 24851301
The same information was mentioned in the technet article I gace you before
0
 

Author Closing Comment

by:GMSMRM
ID: 31603311
Fair enough.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question