SQL Server Broker for the Operations Manager database is disabled

Last week in order to improve performance on our Operations Manager Physical Server we decided to allocate an additional disk from the SAN to the Server. The additional disk space was configured as RAID 0 (L drive).

From there we decided to start moving transaction logs for Databases "OperationsManager", "OperationsManagerAC", "OperationsManagerDW", "ReportServer" and "ReportServerTempDB" onto the new disk (L drive)

After rebooting the Server we noticed that we where now getting the following alert from Operations Manager. The alert is "SQL Service Broker disabled" (see print screen). We ran the query as suggest ALTER DATABASE OperationsManager SET ENABLE_BROKER but the query just kept running continuously with no result!

We also noticed that we while resetting all of our monitors such as the logical disk space monitors the resetting ran ina  continous loop as well!

Does anybody have any suggestions?


scom.doc
makel2Asked:
Who is Participating?
 
wwwallyConnect With a Mentor Commented:
Just follow this article step by step and all should be fine.
http://scug.be/blogs/scom/archive/2008/11/22/the-sql-server-service-broker-for-the-current-opsmgr-database-is-not-enabled.aspx
Your DB is probably still in single user mode and is not accepting the Service account to communicate with the SCOM.

If you want to know if it's set just do the enable broker test first, see article.
Regards,
Walter
http://weblogwally.spaces.live.com
0
 
makel2Author Commented:
Hi Wally,

That fixed the problem thanks very much :-) You are the best ;-) I also noticed that performance on the Operations Manager Server has increased quiet alot now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.